POJ 1862 & ZOJ 1543 Stripies(贪心 | 优先队列)

23 篇文章 0 订阅

题目链接:

PKU:http://poj.org/problem?id=1862

ZJU:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=543


Description

Our chemical biologists have invented a new very useful form of life called stripies (in fact, they were first called in Russian - polosatiki, but the scientists had to invent an English name to apply for an international patent). The stripies are transparent amorphous amebiform creatures that live in flat colonies in a jelly-like nutrient medium. Most of the time the stripies are moving. When two of them collide a new stripie appears instead of them. Long observations made by our scientists enabled them to establish that the weight of the new stripie isn't equal to the sum of weights of two disappeared stripies that collided; nevertheless, they soon learned that when two stripies of weights m1 and m2 collide the weight of resulting stripie equals to 2*sqrt(m1*m2). Our chemical biologists are very anxious to know to what limits can decrease the total weight of a given colony of stripies. 
You are to write a program that will help them to answer this question. You may assume that 3 or more stipies never collide together. 

Input

The first line of the input contains one integer N (1 <= N <= 100) - the number of stripies in a colony. Each of next N lines contains one integer ranging from 1 to 10000 - the weight of the corresponding stripie.

Output

The output must contain one line with the minimal possible total weight of colony with the accuracy of three decimal digits after the point.

Sample Input

3
72
30
50

Sample Output

120.000

Source

Northeastern Europe 2001, Northern Subregion

题意:

就是有一些细胞条纹,他们会碰撞,碰撞后会变为一个新的细胞条纹,碰撞后的重量按照2*sqrt(m1*m2)计算,问最后的最小重量;

PS:

开始半天没读懂题意;



代码一如下:(贪心)

#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
int main()
{
    int n;
    int a[117];
    while(~scanf("%d",&n))
    {
        for(int i = 0; i < n; i++)
        {
            scanf("%d",&a[i]);
        }
        sort(a,a+n);
        double tt = a[n-1];
        for(int i = n-2; i >= 0; i--)
        {
            tt = 2*sqrt(tt*a[i]);
        }
        printf("%.3lf\n",tt);
    }
    return 0;
}

代码二如下:(优先队列)

#include <cstdio>
#include <iostream>
#include <vector>
#include <queue>
#include <cmath>
#include <algorithm>
using namespace std;
int main()
{
    int n;
    double a, b, c, tt;
    priority_queue<double,vector<double>,less<double> > Q;
    while(~scanf("%d",&n))
    {
        while(!Q.empty())
        {
            Q.pop();
        }
        for(int i = 0; i < n; i++)
        {
            scanf("%lf",&a);
            Q.push(a);
        }
        for(int i = 0; i < n-1; i++)
        {
            b = Q.top();
            Q.pop();
            c = Q.top();
            Q.pop();
            tt = 2*sqrt(b*c);
            Q.push(tt);
        }
        printf("%.3f\n",Q.top());
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值