HDU 4493 Tutor(数学)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4493


Problem Description
Lilin was a student of Tonghua Normal University. She is studying at University of Chicago now. Besides studying, she worked as a tutor teaching Chinese to Americans. So, she can earn some money per month. At the end of the year, Lilin wants to know his average monthly money to decide whether continue or not. But she is not good at calculation, so she ask for your help. Please write a program to help Lilin to calculate the average money her earned per month.
 

Input
The first line contain one integer T, means the total number of cases. 
Every case will be twelve lines. Each line will contain the money she earned per month. Each number will be positive and displayed to the penny. No dollar sign will be included.
 

Output
The output will be a single number, the average of money she earned for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign without tail zero. There will be no other spaces or characters in the output.
 

Sample Input
 
 
2 100.00 489.12 12454.12 1234.10 823.05 109.20 5.27 1542.25 839.18 83.99 1295.01 1.75 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00
 

Sample Output
 
 
1581.42100
 

Source

代码如下:

#include <cstdio>
#include <cstring>
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        double a, sum, ans;
        sum = 0;
        for(int i = 1; i <= 12; i++)
        {
            scanf("%lf",&a);
            sum += a;
        }
        ans = sum/12.0;
        int tt1 = ans*1000;
        int tt2 = ans*100;
        if(tt1 %10 >= 5)//四舍五入
        {
            tt2+=1;
        }
        if(tt2%100 == 0)//两个零
        {
            printf("$%.0lf\n",ans);
        }
        else if(tt2%10 == 0)//一个零
        {
            printf("$%.1lf\n",ans);
        }
        else
        {
            printf("$%.2lf\n",ans);
        }
    }
    return 0;
}
/*
10
1.555
1.555
1.555
1.555
1.555
1.555
1.555
1.555
1.555
1.555
1.555
1.555
*/


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值