HDU 2458Kindergarten(二分图 最大团点数)

11 篇文章 0 订阅
8 篇文章 0 订阅

Kindergarten

                                                                       点击打开题目链接
Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 785    Accepted Submission(s): 443


Problem Description
In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.
 

Input
The input consists of multiple test cases. Each test case starts with a line containing three integers
G, B (1 ≤ G, B ≤ 200) and M (0 ≤ M ≤ G × B), which is the number of girls, the number of boys and
the number of pairs of girl and boy who know each other, respectively.
Each of the following M lines contains two integers X and Y (1 ≤ X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other.
The girls are numbered from 1 to G and the boys are numbered from 1 to B.

The last test case is followed by a line containing three zeros.
 

Output
For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.
 

Sample Input
  
  
2 3 3 1 1 1 2 2 3 2 3 5 1 1 1 2 2 1 2 2 2 3 0 0 0
 

Sample Output
  
  
Case 1: 3 Case 2: 4
 

Source
 

题目大意:

   一群小朋友,男的认识全部的男的,部分女生,女生认识全部的女生,认识部分男生,求最后能最多找出多少人,使得他们互相都认识。

团即一个点集,集合中任两个结点相邻。或者说是导出的子图是完全图的点集。极大团(maximal clique):本身为团,再加入任何点都不是。最大团(maximum clique):点最多的团。团数(clique number):最大团的点数。(见http://blog.csdn.net/u012860428/article/details/40623973

   即求最大团点数:

最大团 = 补图的最大独立集

最小覆盖数+最大独立集 = 顶点数

在二分图中 最小覆盖数 = 最大匹配数

最大团 = 补图的最大独立集

最小覆盖数+最大独立集 = 顶点数

在二分图中 最小覆盖数 = 最大匹配数

即建立补图,然后求其最大匹配数;

代码:

#include<iostream>
#include<stdlib.h>
#include<string.h>
#include<stdio.h>
#define max(a,b) a>b?a:b
#define min(a,b) a<b?a:b
#define MAX 210
using namespace std;
int map[MAX][MAX];
int v1,v2;
int visit[MAX];
int l[MAX];
bool dfs(int x)
{
    int i;
    for(i=1;i<=v2;i++)
    {
        if(map[x][i]&&!visit[i])
        {
            visit[i]=1;
            if(l[i]==0||dfs(l[i]))
            {
                l[i]=x;
                return true;
            }
        }
    }
    return false;
}
int nmath()//匈牙利算法求最大匹配数,模板了
{
    int i,ans=0;
    for(i=1;i<=v1;i++)
    {
        memset(visit,0,sizeof(visit));
        if(dfs(i))
            ans++;
    }
    return ans;
}
int main()
{
    int k,m,n,g,b,i,j,ans,cnt=0;
    while(~scanf("%d%d%d",&g,&b,&k)&&(g||b||k))
    {
        memset(map,-1,sizeof(map));
        memset(l,0,sizeof(l));
        v1=g,v2=b;
        while(k--)
        {
            scanf("%d%d",&i,&j);
            map[i][j]=0;
        }
          ans=nmath();
        printf("Case %d: %d\n",++cnt,g+b-ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值