uva 10943How do you add?(简单组合)

Problem A: How do you add?

Larry is very bad at math - he usually uses a calculator, which worked well throughout college. Unforunately, he is now struck in a deserted island with his good buddy Ryan after a snowboarding accident. They're now trying to spend some time figuring out some good problems, and Ryan will eat Larry if he cannot answer, so his fate is up to you! 

It's a very simple problem - given a number  N , how many ways can  K  numbers less than N  add up to  N

For example, for N = 20 and K = 2, there are 21 ways: 
0+20 
1+19 
2+18 
3+17 
4+16 
5+15 
... 
18+2 
19+1 
20+0 


Input

Each line will contain a pair of numbers  N  and  K N  and  K  will both be an integer from 1 to 100, inclusive. The input will terminate on 2 0's.

Output

Since Larry is only interested in the last few digits of the answer, for each pair of numbers  N  and  K , print a single number mod 1,000,000 on a single line. 

Sample Input

20 2
20 2
0 0

Sample Output

21
21
 
题意:给你n和k,让你求出有k个数的和为n的种类数(可以为0);很明显的插板法,把n看成n个1,因为可以为0,所以还要加上k个0,即 1 1 1 1 .............0 0 0 0,然后共有n+k-1个空,插入k-1个板,这样的最终结果
 
代码:
#include <iostream>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<vector>
#include<stdlib.h>
#include<string>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<set>
#define inf 0x3f3f3f3f
#define eps 1e-5
#define max(a,b) (a)>(b)?(a):(b)
#define min(a,b) (a)<(b)?(a):(b)
#define N 210
#define MOD 1000000
using namespace std;
int c[N+1][N+1];
void init()
{
    int i,j;
    c[0][0]=1;
    for(i=1;i<=N;i++)
    {
        c[i][0]=1;
        for(j=1;j<N;j++)
        {
            c[i][j]=(c[i-1][j]%MOD+c[i-1][j-1]%MOD)%MOD;
        }
        c[i][N]=1;
    }
}
int main()
{
    int n,k,ans,i;
    init();
    while(~scanf("%d%d",&n,&k)&&(n||k))
    {
        printf("%d\n",c[n+k-1][k-1]);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值