Is Bigger Smarter?+uva+简单dp(最长公共升降子序列的变形)

Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu

Description

Download as PDF

Question 1: Is Bigger Smarter?

The Problem

Some people think that the bigger an elephant is, the smarter it is. To disprove this, you want to take the data on a collection of elephants and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the IQ's are decreasing.

The input will consist of data for a bunch of elephants, one elephant per line, terminated by the end-of-file. The data for a particular elephant will consist of a pair of integers: the first representing its size in kilograms and the second representing its IQ in hundredths of IQ points. Both integers are between 1 and 10000. The data will contain information for at most 1000 elephants. Two elephants may have the same weight, the same IQ, or even the same weight and IQ.

Say that the numbers on the i-th data line are W[i] and S[i]. Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing an elephant). If these n integers are a[1]a[2],..., a[n] then it must be the case that

   W[a[1]] < W[a[2]] < ... < W[a[n]]
and
   S[a[1]] > S[a[2]] > ... > S[a[n]]
In order for the answer to be correct,  n should be as large as possible. All inequalities are strict: weights must be strictly increasing, and IQs must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.

Sample Input

6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900

Sample Output

4
4
5
9
7
 
  
解决方案:直接按照最长公共升降子序列的思想。dp[i]=max{dp[j]+1|a[i]>a[j]},最长公共生子序列
code:
#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<stack>
using namespace std;
int dp[1003];
const int maxn=1003;
struct node
{
    int p;
    int W,S;
} N[maxn];
bool cmp(node a,node b)
{
    if(a.W!=b.W)return a.W<b.W;
    else return a.S>b.S;
}
int fa[1003];
int main()
{
    memset(dp,0,sizeof(dp));
    memset(fa,-1,sizeof(fa));
    int i=1;
    while(~scanf("%d%d",&N[i].W,&N[i].S))
    {
        N[i].p=i;
        i++;
    }
    sort(N+1,N+1+i,cmp);
    int st=1,Max=0;
    for(int j=1; j<=i; j++)
    {
        dp[j]=1;
        for(int k=1; k<j; k++)
        {
            if(N[j].W>N[k].W&&N[j].S<N[k].S)
            {
                if(dp[j]<dp[k]+1)
                {
                 dp[j]=dp[k]+1;
                 fa[j]=k;
                }
            }
        }
        if(dp[j]>Max){
            Max=dp[j];
            st=j;
        }
    }
    printf("%d\n",Max);
    stack<int>S;
    S.push(st);
    while(fa[st]!=-1){
        S.push(fa[st]);
        st=fa[st];
    }
    while(!S.empty()){
        int s=S.top();
        printf("%d\n",N[s].p);
        S.pop();
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值