Rotating Sentences

In ``Rotating Sentences,'' you are asked to rotate a series of input sentences 90 degrees clockwise. So instead of displaying the input sentences from left to right and top to bottom, your program will display them from top to bottom and right to left.

Input and Output

As input to your program, you will be given a maximum of 100 sentences, each not exceeding 100 characters long. Legal characters include: newline, space, any punctuation characters, digits, and lower case or upper case English letters. (NOTE: Tabs are not legal characters.)

The output of the program should have the last sentence printed out vertically in the leftmost column; the first sentence of the input would subsequently end up at the rightmost column.

Sample Input

Rene Decartes once said,
"I think, therefore I am."

Sample Output

"R
Ie
 n
te
h 
iD
ne
kc
,a
 r
tt
he
es
r
eo
fn
oc
re
e
 s
Ia
 i
ad
m,
.
"
#include <stdio.h>
#include <string.h>

int main()
{
    static char a[101][101];
    char *p[101];
    int n = 0,i = 0;
    int len_max = 0,len = 0;
    

    while (gets (a[n]) != NULL)
    {
        len = strlen (a[n]);
        if (n == 0)
            len_max = len;

        len_max = len_max> len ? len_max : len;
        p[n] = a[n];
        n++;
    }

    while (len_max--)
    {
        for (i = n - 1; i >= 0; i--)
        {
            if (*p[i] != '\0')
            {
                putchar (*p[i]);
                p[i]++;
            }
            else
            {
                if (i > 0)
                putchar (' ');
            }
        }
        putchar ('\n');
    }

    return 0;
}

 

指针的使用。


                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值