2014ACM集训13级PK赛3-Taxi Fare

Description

Last September, Hangzhou raised the taxi fares.

The original flag-down fare in Hangzhou was 10 yuan, plusing 2 yuan per kilometer after the first 3km and 3 yuan per kilometer after 10km. The waiting fee was 2 yuan per five minutes. Passengers need to pay extra 1 yuan as the fuel surcharge.

According to new prices, the flag-down fare is 11 yuan, while passengers pay 2.5 yuan per kilometer after the first 3 kilometers, and 3.75 yuan per kilometer after 10km. The waiting fee is 2.5 yuan per four minutes.

The actual fare is rounded to the nearest yuan, and halfway cases are rounded up. How much more money does it cost to take a taxi if the distance is d kilometers and the waiting time is t minutes.

Input

There are multiple test cases. The first line of input is an integer T ≈ 10000 indicating the number of test cases.

Each test case contains two integers 1 ≤ d ≤ 1000 and 0 ≤ t ≤ 300.

Output

For each test case, output the answer as an integer.

Sample Input

4
2 0
5 2
7 3
11 4

Sample Output

0135

 

 

#include <stdio.h>
#include <math.h>
#include <stdlib.h>

int main()
{
    int N;
    scanf ("%d",&N);
    while (N--)
    {
        int d,t;
        double ans1,ans2;
        scanf ("%d%d",&d,&t);
        if (d <= 3)
        {
            ans1 = (double)10 + 1 + 0.4 * t;
            ans2 = (double)11 + 0.625 * t;
        }else if (d <= 10)
        {
            ans1 = (double)11 + 0.4 * t + (d - 3) * 2;
            ans2 = (double)11 + 0.625 * t + (d - 3) * 2.5;
        }else
        {
            ans1 = (double)11 + 0.4 * t + 7 * 2 + (d - 10) * 3;
            ans2 = (double)11 + 0.625 * t + 7 * 2.5 + (d - 10) * 3.75;
        }
        int a = ans1 + 0.5,b = ans2 + 0.5;
        int ans = fabs (a - b);
        printf ("%d\n",ans);
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值