九度OJ-1124-Digital Roots

  此题的关键在于:题目提示The integer may consist of a large number of digits.,故要考虑到输入数字会产生溢出。所以对初始输入要采取字符串的形式加以记录。若输入字符串长度在0~1000范围内,那么得到的初始root一定在0~9000范围内,则不会产生溢出,故所有root都可以用int类型进行存储。得到初始root后进行判断,不符合条件则可继续对整型数据root进行逐位加和直到满足条件。

题目地址:点击打开链接 题目描述:

    The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

    For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

输入:

    The input file will contain a list of positive integers, one per line. 
    The end of the input will be indicated by an integer value of zero.

输出:

    For each integer in the input, output its digital root on a separate line of the output.

样例输入:
24
39
0
样例输出:
6
3
提示:

The integer may consist of a large number of digits.

来源:
2008年北京大学方正实验室计算机研究生机试真题
答疑:
解题遇到问题?分享解题心得?讨论本题请访问: http://t.jobdu.com/thread-7847-1-1.html
#include <iostream>
using namespace std;

int main(){
	char buf[1000];
	int root;
	int temp;
	while (cin>>buf,buf[0]!='0'){
		//initiate
		root=0;
		//process
		for (int i=0;buf[i]!='\0';i++){
			root+=buf[i]-'0';
		} 
		while (root>9){//若root非一位数,则进行内while求root 
			temp=root;
			root=0;
			while (temp>0){
				root+=temp%10;
				temp/=10;
			} 
		}
		//output
		cout<<root<<endl;
	}
	return true;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值