POJ3468 A Simple Problem with Integers(线段树成段更新,区间查询)

A Simple Problem with Integers

Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 72201 Accepted: 22282
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4


Sample Output

4
55
9
15

解题思路:

本题一看,AC数那么高,其实感觉手写还是不易,关键理解线段树成段更新,区间查询的要点就行,很多人估计是套模版过的吧,但是还是理解一下线段树的一些策略比较好,比如懒惰处理,为什么需要懒惰处理(pushdown)呢,因为如果每层都更新的话太花费时间了,因为有时你并不需要查询所有的结点,所以要查询的时候再去更新结点就行,所以就有了懒惰处理。其他的倒是没有什么值得注意的地方,套线段树的模版就行。


AC代码:

#include<iostream>
using namespace std;

const int maxn = 100010;
typedef long long LL;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1

LL add[maxn<<2]; //4 * maxn
LL sum[maxn<<2];

void PushUP(int rt)
{
	sum[rt] = sum[rt<<1] + sum[rt<<1|1];	
}

void PushDown(int rt,int m)  //懒惰,往下传递值,子节点需要查询的时候再更新 
{
	if(add[rt])
	{
		add[rt<<1] += add[rt];  //接受父节点传递来的值 
		add[rt<<1|1] += add[rt]; 
		sum[rt<<1] += (m>>1) * add[rt]; //父节点有2*N个子节点,那么子节点就要/2为N 
		sum[rt<<1|1] += (m>>1) * add[rt];
		add[rt] = 0; //父节点的值传递后,要清空 
	}	
}

void Build(int l,int r,int rt)
{
	add[rt] = 0;
	if(l == r)
	{
		cin>>sum[rt];
		return;
	}
	int m = (l + r) / 2;
	Build(lson);
	Build(rson);
	PushUP(rt);  //等价于父节点等于两个子节点的和 
}

void Update(int L,int R,int c,int l,int r,int rt)  //c为增加的值 
{
	if(L <= l && R >= r)
	{
		add[rt] += c;
		sum[rt] += (LL)	c * (r - l + 1); //每个数+c,区间中一共有r - l + 1个
		return; 
	}	
	PushDown(rt,r-l+1);//加上后懒惰传递.
	int m = (l + r) >> 1;
	if(L <= m)
		Update(L,R,c,lson); //更新左子树
	if(R > m)
		Update(L,R,c,rson); //更新右子树
	PushUP(rt); //等价于父节点等于两个子节点的和 
}

LL Query(int L,int R,int l,int r,int rt) //L,R为需要查询的区间 
{
	if(L <= l && R >= r)
	{
		return sum[rt];
	}	
	PushDown(rt,r-l+1); //当前结点和区间内一共有多少个结点, 
	int m = (l + r) >> 1; 
	LL ret = 0;
	if(L <= m) ret += Query(L,R,lson);
	if(R > m) ret += Query(L,R,rson);
	return ret;
}

int main()
{
	int m,n;
	int i;
	char str;
	while(cin>>m>>n)
	{
		Build(1,m,1);
		while(n--)
		{
			int num1,num2,num3;
			cin>>str;
			if(str == 'Q')
			{
				cin>>num1>>num2;
				cout<<Query(num1,num2,1,m,1)<<endl;
			}
			else
			{
				cin>>num1>>num2>>num3;
				Update(num1,num2,num3,1,m,1);
			}
		}
	}
	return 0;	
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值