POJ3278 Catch That Cow(广搜BFS)

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 54969 Accepted: 17198

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

题目大意:

给定一个初始值m,一个终值n,有三种方法分别为m + 1,m - 1,m * 2,求用最小的步数刚好等于n。

解题思路:

最小距离,想到了广搜,广搜用队列解就可以,由于元素可能为0,所以m-1可能出现-1的情况,然而数组下标不能为-1,然后就开始一直RE,在POJ discuss上发现有人也是被坑了,果断改了,然后就AC了。

AC代码:

#include<iostream>
#include<queue>
using namespace std;

const int maxn = 200010;
int step[maxn];
bool vis[maxn];
int m,n;

void bfs()
{
	int start = m;
	int final = n;
	queue<int> que;
	que.push(start);
	vis[start] = true;
	while(!que.empty())
	{
		int element = que.front();
		que.pop();
		if(element + 1< maxn && !vis[element + 1]) //如果不越界又没有标记过,就加入队列 
		{
			que.push(element + 1);
			vis[element + 1] = true;
			step[element + 1] = step[element] + 1; //当前这个状态(element)到(element+1)一共经历了一步 
		}
		if(element - 1< maxn && !vis[element - 1] && element != 0)  //此处要特别注意,如果element刚好为0的时候,数组下标为-1,re. 
		{
			que.push(element - 1);
			vis[element - 1] = true;
			step[element - 1] = step[element] + 1; //当前这个状态(element)到(element-1)一共经历了一步 
		}
		if(element * 2 < maxn && !vis[element * 2])
		{
			que.push(element * 2);
			vis[element * 2] = true;
			step[element * 2] = step[element] + 1; //当前这个状态(element)到(element*2)一共经历了一步 
		}
		if(vis[final])
		{
			cout<<step[final]<<endl;
			break;
		}
	}
}

int main()
{
	int i;
	while(cin>>m>>n)
	{
		if(m == n)   
		{
			cout<<"0"<<endl;
			return 0;
		}
		else
		{
			for(i=0;i<=200000;i++)
			{
				step[i] = 0;
				vis[i] = false;
			}
		}
		bfs();
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值