关闭

The method of type serviceimpl must override a superclass method解决方式

标签: javaeclipseOverridemyeclipse
19人阅读 评论(0) 收藏 举报
分类:

如果你用的是eclipse

在使用 @Override 时出现以下错误信息: 

The method of type serviceimpl must override a superclass method

那是因为你的Compiler 是jdk1.5,只要把它改为 1.6就可以了 


方法:

第一步: 

1. window ->preferences... -> java -> Compiler 

2. Compiler compliance level : 1.6

3.Apply 

4. ok  

5.完成 






第二步

把项目的JRE变成6.0的
项目右键->build path->configure build path->java Compiler(左边那排中) ->在右边的Compiler compliance level 修改版本为1.6








0
0

猜你在找
【直播】机器学习&数据挖掘7周实训--韦玮
【套餐】系统集成项目管理工程师顺利通关--徐朋
【直播】3小时掌握Docker最佳实战-徐西宁
【套餐】机器学习系列套餐(算法+实战)--唐宇迪
【直播】计算机视觉原理及实战--屈教授
【套餐】微信订阅号+服务号Java版 v2.0--翟东平
【直播】机器学习之矩阵--黄博士
【套餐】微信订阅号+服务号Java版 v2.0--翟东平
【直播】机器学习之凸优化--马博士
【套餐】Javascript 设计模式实战--曾亮
查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:20次
    • 积分:10
    • 等级:
    • 排名:千里之外
    • 原创:1篇
    • 转载:0篇
    • 译文:0篇
    • 评论:0条
    文章分类
    文章存档