UVALive 4260 Fortune Card Game (Regionals 2008 Asia Taipei +DP)

【题目链接】:click here~~

【题目大意】:


A popular card game called ``fortune" is getting popular in country X. Fig. 1 shows one of the cards. In each card, a positive integer number (20 in the figure) is listed as the address of the card. A symbol is drawn beside the address. There are five kinds of symbols, which are listed below the card. For convenience, let each symbol be represented by an English letter from `A'-`E'. The bottom of a card contains another number called ``next fortune number."

\epsfbox{p4260.eps}

Figure 1: A sample fortune card and symbols.

In a set of fortune cards, many cards can have same address; that is, address 20 is not limited to appear only in one card. However, there will be no cards that are identical, i.e., no two cards with same address, symbol, and next fortune number.

The fortune card game is played as follows. A player starts with cards that have address 1. The goal of the game is trying to complete a ``spell" that is composed by the symbols. For example, let a spell be ``BADDAD". In the first move, the player will look for cards that have address 1 with a star symbol (which matches `B' in the spell). The next fortune numbers of these cards are the new addresses for the next move. The player can select one card to advance to a new address x. The selected card is then put back to the cards for next move but the fortune number is written down.

Let the example be continued. In the next move, the player needs to look for the cards that have new address x with the cross symbol (which matches the second `A' in the spell). Again, the player selects one card to advance to another new address. This procedure continues until the spell ``BADDAD" is completed. Once the player completes a spell, he wins a score by adding all the next fortune numbers of the selected card, which have been written down.

Given a spell and a set of fortune cards, please output the maximum score that can be played in this card game.


Technical Specification


  1. N - the number of test cases, N$ \le$10 .
  2. C - the number of cards, C$ \le$800 .
  3. L - the length of a spell, L$ \le$150 .

Input 

Test data begins with an integer N which is the number of test cases. Each test case begins with an integer C, which is the number of cards. Following the number C is C lines of card information. Each card is represented by (Address Symbol NextF ortuneNumber). The address and next fortune number are between 1 and 800. The symbols are capital letters from `A' to `E'. The last line of a test case is a spell. The spell is a string composed by capital letters from `A' to `E'. The length of the spell (L ) is less than 150.

Output 

For each test case, please output the maximum score that can be collected for each test case.

Sample Input 

2 
7 
1 A 2 
1 A 3 
2 A 3 
2 B 4 
2 B 5 
3 A 3 
3 B 4 
AAAAB 
6 
1 A 2 
1 B 2 
1 A 3 
1 B 3 
2 A 3 
2 B 3 
AB

Sample Output 

16 
5
【题目大意】:玩家控制一个卡牌游戏,n张卡片,每张有三个属性,ai:地址,s:卡牌字母,bi:卡牌价值,给你一个固定spell拼音字母序列,求集成所有拼音字母序列得到的最大价值,规则,若选择一张卡牌,则该张卡牌的价值属性是变成下一次寻找的卡牌的地址属性 。

【思路】比赛的时候读题太急,有些关键部分没有搞清楚,导致最后调试好久,赛后发现其实有更简单,暴力的做法:定义dp[i][j]:表示第i个卡牌属性为j的最大价值,则有递推关系:dp[i][st[j].bi]=max(dp[i][st[j].bi],dp[i-1][st[j].ai]+st[j].bi);

The next fortune numbers of these cards are the new addresses for the next move
注意这句话,是说选取的的卡牌的价值属性作为下一次的卡牌的地址,关键点解释dp[i-1][st[j].ai]+st[j].bi这个状态转移

代码:

/*
* Problem: UVALive 4260
* Running time: 46MS
* Complier: G++
* Author: javaherongwei
* Create Time: 20:16 2015/10/14 星期三
*/
#include <bits/stdc++.h>
using namespace std;
const int maxn=1e3+10;
const int inf=0x3f3f3f3f;
inline int max(int a,int b){return a>b?a:b;}
inline int min(int a,int b){return a<b?a:b;}
struct node
{
    int ai,bi;
    char s;
} st[maxn];
string str;
int dp[maxn][maxn];
int main()
{
    
    //freopen("2.txt","r",stdin);
    int t;cin>>t;
    while(t--)
    {
        int n;cin>>n;
        for(int i=1; i<=n; ++i){
            cin>>st[i].ai>>st[i].s>>st[i].bi;
        }
        cin>>str;
        int len=str.size();
        memset(dp,-inf,sizeof(dp));
        dp[0][1]=0;///dp[i][j]:表示当前第i个卡片值属性为j的最大值
        for(int i=1; i<=len; ++i){///枚举结果字母序列
            for(int j=1; j<=n; ++j){///枚举第j个卡片
                if(st[j].s!=str[i-1]) continue;///如果当前枚举的卡片不对应spell里的卡片,continue
                dp[i][st[j].bi]=max(dp[i][st[j].bi],dp[i-1][st[j].ai]+st[j].bi);
               // cout<<"dp[i][j]= "<<dp[i][j]<<endl;
            }
        }
        int ans=0;
        for(int i=1; i<=n; ++i)
            ans=max(ans,dp[len][i]);
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值