HDU5583 Kingdom of Black and White

Kingdom of Black and White

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 65    Accepted Submission(s): 33


Problem Description
In the Kingdom of Black and White (KBW), there are two kinds of frogs: black frog and white frog.

Now   N  frogs are standing in a line, some of them are black, the others are white. The total strength of those frogs are calculated by dividing the line into minimum parts, each part should still be continuous, and can only contain one kind of frog. Then the strength is the sum of the squared length for each part.

However, an old, evil witch comes, and tells the frogs that she will change the color of   at most one  frog and thus the strength of those frogs might change.

The frogs wonder the   maximum  possible strength after the witch finishes her job.
 

Input
First line contains an integer   T , which indicates the number of test cases.

Every test case only contains a string with length   N , including only   0  (representing
a black frog) and   1  (representing a white frog).

  1T50 .

 for 60% data,   1N1000 .

 for 100% data,   1N105 .

 the string only contains 0 and 1.
 

Output
For every test case, you should output " Case #x: y",where   x  indicates the case number and counts from   1  and   y  is the answer.
 

Sample Input
  
  
2 000011 0101
 

Sample Output
  
  
Case #1: 26 Case #2: 10
 

Source
 

先离散化,求出结果,如果全部的颜色都一样则不用改变就是最优。

离散化之后,然后枚举每个离散块,尝试改变每个离散块两边的青蛙的颜色,更新最大值。

/****************
*PID:hdu5583
*Auth:Jonariguez
*****************
*/
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <vector>
#include <algorithm>
using namespace std;
typedef long long LL;

const int maxn=100000+10;
char s[maxn];
LL a[maxn];

int main()
{
    LL i,j,n,m,T,kcase=1;
    scanf("%I64d",&T);
    while(T--){
        scanf("%s",s+1);
        n=strlen(s+1);
        LL cnt=0;
        LL res=0;
        for(i=1;i<=n;){ //离散化
            j=i;
            while(j<=n && s[j]==s[i]) j++;
            a[cnt]=j-i;
            res+=a[cnt]*a[cnt];cnt++;
            i=j;
        }
        printf("Case #%I64d: ",kcase++);
        if(cnt==1){         //只要一种颜色
            printf("%I64d\n",res);continue;
        }
        LL ans=res;
        for(i=0;i<cnt;i++){
            LL t=res;
            if(a[i]==1){        //如果该离散块只有一个,则改变它时会影响左右两边的块
                LL now=a[i];
                t-=a[i]*a[i];
                if(i<cnt-1){
                    now+=a[i+1];
                    t-=a[i+1]*a[i+1];
                }
                if(i){
                    now+=a[i-1];
                    t-=a[i-1]*a[i-1];
                }
                t+=now*now;
                ans=max(ans,t);
            }else{
                if(i){
                    LL temp=res;
                    temp-=a[i]*a[i];
                    temp-=a[i-1]*a[i-1];
                    temp+=(a[i-1]+1)*(a[i-1]+1);
                    temp+=(a[i]-1)*(a[i]-1);
                    ans=max(ans,temp);
                }
                if(i<cnt-1){
                    LL temp=res;
                    temp-=a[i]*a[i];
                    temp-=a[i+1]*a[i+1];
                    temp+=(a[i+1]+1)*(a[i+1]+1);
                    temp+=(a[i]-1)*(a[i]-1);
                    ans=max(ans,temp);
                }
            }
        }
        printf("%I64d\n",ans);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值