1006

Problem F

Time Limit : 3000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 7   Accepted Submission(s) : 1
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

After little Jim learned Fibonacci Number in the class , he was very interest in it.
Now he is thinking about a new thing -- Fibonacci String .

He defines : str[n] = str[n-1] + str[n-2] ( n > 1 )

He is so crazying that if someone gives him two strings str[0] and str[1], he will calculate the str[2],str[3],str[4] , str[5]....

For example :
If str[0] = "ab"; str[1] = "bc";
he will get the result , str[2]="abbc", str[3]="bcabbc" , str[4]="abbcbcabbc" …………;

As the string is too long ,Jim can't write down all the strings in paper. So he just want to know how many times each letter appears in Kth Fibonacci String . Can you help him ?

Input

The first line contains a integer N which indicates the number of test cases.
Then N cases follow.
In each case,there are two strings str[0], str[1] and a integer K (0 <= K < 50) which are separated by a blank.
The string in the input will only contains less than 30 low-case letters.

Output

For each case,you should count how many times each letter appears in the Kth Fibonacci String and print out them in the format "X:N".
If you still have some questions, look the sample output carefully.
Please output a blank line after each test case.

To make the problem easier, you can assume the result will in the range of int.

Sample Input

1
ab bc 3

Sample Output

a:1
b:3
c:2
d:0
e:0
f:0
g:0
h:0
i:0
j:0
k:0
l:0
m:0
n:0
o:0
p:0
q:0
r:0
s:0
t:0
u:0
v:0
w:0
x:0
y:0
z:0


水题  递推


代码


#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
__int64 hash[60];
void add()
{
    int j;
    hash[0]=1;
    hash[1]=0;
    for(j=2; j<=50; j++)
        hash[j]=hash[j-1]+hash[j-2];
}
__int64 has[60];
void add_()
{
    int j;
    has[0]=0;
    has[1]=1;
    for(j=2; j<=50; j++)
        has[j]=has[j-1]+has[j-2];
}
int main()
{
    int t;
    char a[40],b[40],c;
    int n;
    int j,k,l=1;
    __int64 sun[26],sum[26];
    add();
    add_();
    cin>>t;
    while(t--)
    {


        memset(sun,0,sizeof(sun));
        memset(sum,0,sizeof(sum));
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        cin>>a;
        getchar();
        for(j=0; j<30; j++)
            sun[a[j]-97]+=1;
        cin>>b;
        getchar();
        for(j=0; j<30; j++)
            sum[b[j]-97]+=1;
        cin>>n;
        //if(l==0) cout<<endl;
        //l=0;
        for(j=0; j<26; j++)
        {
            c=j+97;
            cout<<c<<":"<<hash[n]*sun[j]+has[n]*sum[j]<<endl;
        }
        cout<<endl;
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值