HDU 1560DNA sequence

22 篇文章 0 订阅

DNA sequence

Time Limit : 15000/5000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 8   Accepted Submission(s) : 1
Problem Description
The twenty-first century is a biology-technology developing century. We know that a gene is made of DNA. The nucleotide bases from which DNA is built are A(adenine), C(cytosine), G(guanine), and T(thymine). Finding the longest common subsequence between DNA/Protein sequences is one of the basic problems in modern computational molecular biology. But this problem is a little different. Given several DNA sequences, you are asked to make a shortest sequence from them so that each of the given sequence is the subsequence of it.

For example, given "ACGT","ATGC","CGTT" and "CAGT", you can make a sequence in the following way. It is the shortest but may be not the only one.

 

Input
The first line is the test case number t. Then t test cases follow. In each case, the first line is an integer n ( 1<=n<=8 ) represents number of the DNA sequences. The following k lines contain the k sequences, one per line. Assuming that the length of any sequence is between 1 and 5.
 

Output
For each test case, print a line containing the length of the shortest sequence that can be made from these sequences.
 

Sample Input
  
  
1 4 ACGT ATGC CGTT CAGT
 

Sample Output
  
  
8
 

Author
LL
 

Source
HDU 2006-12 Programming Contest


找到最短的DNA序列  其子序列包含题意所给的DNA

IDA*  估价函数为最长剩余DNA数量


#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<cmath>
#include<string>
#include<vector>
#include<algorithm>
#include<map>
#include<set>
#define inf 1<<30
#define LL long long
#define maxn 1<<24
using namespace std;
char str[10][10];//保存DNA
int l[10];
int t,n;
int tlen;
bool flag;

int get_h(int * a)  //估价函数
{
    int ans=0;
    for(int i=0; i<n; i++)
    {
        ans=max(ans,a[i]);
    }
    return ans;
}

void dfs(int len,int * a)
{
    if(flag) return ;

    if(get_h(a)>len) return ;//预估值小于最优估计值

    if(len==0)  //找到序列
    {
        flag=true ;
        return  ;
    }

    bool vis[10];
    memset(vis,false ,sizeof(vis));
    for(int i=0; i<n; i++)
    {
        if(a[i]==0||vis[i]) continue ;
        int ee[10];
        for(int ii=0; ii<n; ii++)
            ee[ii]=a[ii];
        vis[i]=true ;
        char ch=str[i][l[i]-a[i]];
        ee[i]--;
        for(int j=i+1; j<n; j++)
        {
            if(ee[j]==0||vis[j]) continue ;
            if(str[j][l[j]-a[j]]==ch)
            {
                vis[j]=true ;
                ee[j]--;
            }
        }
        dfs(len-1,ee);
    }
    return  ;
}

int main()
{
    scanf("%d",&t);
    while(t--)
    {
        tlen=0;
        flag=false ;
        scanf("%d",&n);
        int ee[10];
        for(int i=0; i<n; i++)
        {
            scanf("%s",str[i]);
            ee[i]=strlen(str[i]);
            l[i]=ee[i];
            tlen=max(ee[i],tlen);
        }
        while(1)
        {
            dfs(tlen,ee);
            if(flag)
                break;
            tlen++;
        }
        printf("%d\n",tlen);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值