poj 1655Balancing Act(找重心,树形dp)

Balancing Act
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10375 Accepted: 4296

Description

Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a forest: a collection of one or more trees. Define the balance of a node to be the size of the largest tree in the forest T created by deleting that node from T. 
For example, consider the tree: 

Deleting node 4 yields two trees whose member nodes are {5} and {1,2,3,6,7}. The larger of these two trees has five nodes, thus the balance of node 4 is five. Deleting node 1 yields a forest of three trees of equal size: {2,6}, {3,7}, and {4,5}. Each of these trees has two nodes, so the balance of node 1 is two. 

For each input tree, calculate the node that has the minimum balance. If multiple nodes have equal balance, output the one with the lowest number. 

Input

The first line of input contains a single integer t (1 <= t <= 20), the number of test cases. The first line of each test case contains an integer N (1 <= N <= 20,000), the number of congruence. The next N-1 lines each contains two space-separated node numbers that are the endpoints of an edge in the tree. No edge will be listed twice, and all edges will be listed.

Output

For each test case, print a line containing two integers, the number of the node with minimum balance and the balance of that node.

Sample Input

1
7
2 6
1 2
1 4
4 5
3 7
3 1

Sample Output

1 2

Source

[Submit]   [Go Back]   [Status]   [Discuss]


树的重心定义为:找到一个点,其所有的子树中最大的子树节点数最少,那么这个点就是这棵树的重心,删去重

心后,生成的多棵树尽可能平衡.  实际上树的重心在树的点分治中有重要的作用, 可以避免N^2的极端复杂度(从退化链的一端出发),保证NlogN的复杂度,树的重心可以采用树形dp求解.令siz[x]表示以x为根的子树节点数目,f[x]表示以x为根的子树v中最大的siz[v]。要注意x的父亲在这种情况下是没法统计进来的,我们可以用总的节点数减去siz[x],就能得到以x的父亲为根的子树大小。



#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<queue>
#include<cstring>
using namespace std;
const int maxn = 2e4 + 10;
const int inf = 1e8;
int siz[maxn],f[maxn],root,tot,res;
vector<int>G[maxn];
void AddEdge(int u,int v)
{
	G[u].push_back(v);
	G[v].push_back(u);
}
void getroot(int u,int fa)
{
	siz[u] = 1;f[u] = 0;
	for(int i = 0; i < G[u].size(); ++i) {
		int v = G[u][i];
		if(v==fa)continue;
		getroot(v,u);
		siz[u] += siz[v];
		f[u] = max(f[u],siz[v]);
	}
	f[u] = max(f[u],tot - siz[u]);
	int t = f[u];
	if(f[u] < f[root]) root = u,res = t;
	if(u < root && f[u] == f[root]) root = u,res = t;
}
int getsize(int u,int fa)
{
	int ans = 1;
	for(int i = 0; i < G[u].size(); i++) {
		int v = G[u][i];
		if(v==fa)continue;
		ans += getsize(v,u);
	}
	return ans;
}
int main(int argc, char const *argv[])
{
	int T;scanf("%d",&T);
	while(T--) {
		int n;scanf("%d",&n);
		tot = n;
		f[root = 0] = inf;
		for(int i = 1; i <= n; i++) {
			G[i].clear();
		}
		for(int i = 1; i < n; i++) {
			int u,v;scanf("%d%d",&u,&v);
			AddEdge(u,v);
		}
		getroot(1,-1);
		printf("%d %d\n", root,res);
	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值