cocoapods导入Nimbus库报错

原创 2015年11月18日 18:16:42

错误类型:Too many arguments to function call, expected 0, have 3

这几天做项目用到Nimbus,用cocoapods导入,出现15个错误,报的错为Too many arguments to function call, expected 0, have 3 

在网上找了很多关于Nimbus出现这个错误的解决方案,资料并不是很多,具体解决方案如下:

1.点击pods

2.在targets中选中Nimbus

3.选择Build Settings

4.搜索objc

5.将Enable Strict Checking of objc_msgSend Calls 改为 NO


版权声明:本文为博主原创文章,未经博主允许不得转载。

相关文章推荐

CocoaPods一个Objective-C第三方库的管理利器

介绍:开发应用的时候第三方的库是不可缺少的,能提高开发的效率。 一些经常用到的库,在新的项目里用是,你又得手工的Add到项目里,用的到库多起来了,就不方便管理了。发现CocoaPods这个软件,可以帮...

使用cocoapods导入第三方后 报错_OBJC_CLASS_$_XXX

欢迎使用Markdown编辑器写博客我们手动导入第三方库的时候,感觉管理不是很方便,于是会选择使用Cocoapods管理。现在记录一下使用心得,当使用cocoapods导入afnetworking或者...
  • dxxzst
  • dxxzst
  • 2017年07月28日 17:41
  • 224

iOS开发:CocoaPods更新项目Pods里的库报错 error: RPC failed; curl 56 SSLRead() return error -9806

error: RPC failed; curl 56 SSLRead() return error -9806
  • CC1991_
  • CC1991_
  • 2017年03月14日 10:40
  • 3264

升级10.11后Xcode的CocoaPods插件报错

错误信息如图所示问题已解决,下面有解决方法,遇到相同问题的同学可以看看.另外补充,10.11 cocoapods安装命令: sudo gem install -n /usr/local/bin coc...

The dependency `ReactiveCocoa` is not used in any concrete target.(Cocoapods报错)

The dependency `` is not used in any concrete target The dependency `AFNetworking ` is not used in a...

Xcode8下面 cocoapods升级报错

在跟新Xcode8之后CocoaPods 失效 1.问题: 使用:  bogon:~ zhanglizhi$ vim Podfile bogon:~ zhanglizhi$ pod install...

CocoaPods的SSL报错解决办法

最近把CocoaPods升级到0.38之后导入高德地图的SDK. pod install终端一直提示这个错误: Failed to send stats: SSL_connect returned...
  • kareily
  • kareily
  • 2015年10月08日 10:25
  • 1897

xcode8 cocoapods 执行 pod spec lint 报错

这个问题坑了一天多,一直报错: xcodebuild  无法运行,找不到app.xcworkspace,而且还有 后来不停的翻阅资料,重装cocoapods,到最后才知道,mao sh sa...

iOS开发-CocoaPods使用详细说明以及解决部分报错

一、概要 iOS开发时,项目中会引用许多第三方库,CocoaPods(https://github.com/CocoaPods/CocoaPods)可以用来方...

Xcode路径改变导致CocoaPods报错的解决办法

这几天心血来潮,更新了下Mac系统,然后装了下Xcode8装逼,接下来就懵逼了。 由于之前的Xcode是7.1的一直没升级,本想体验体验Xcode8的,所以装完Xcode8之后Xcode7.1也没有...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:cocoapods导入Nimbus库报错
举报原因:
原因补充:

(最多只允许输入30个字)