多重背包——POJ 1276

对应POJ题目:点击打开链接

Cash Machine
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 28987 Accepted: 10377

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, 

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 

Notes: 
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: 

cash N n1 D1 n2 D2 ... nN DN 

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0

Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash. 

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash. 

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

题意:提款机有n种面值的纸币 ,每种面值纸币有k张,给出一个需求量,问提款机能取到的不超过需求量的最大总额。


思路:多重背包转化为01背包,使用二进制思想降低时间复杂度(具体见背包九讲)。


#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define M 100010
#define MAX(x, y) ((x) > (y) ? (x) : (y))
int v[220000];
int dp[M];

int main()
{
	//freopen("in.txt", "r", stdin);
	int check, n, i, j, u, k, c;
	while(~scanf("%d", &check))
	{
		memset(dp, 0, sizeof(dp));
		scanf("%d", &n);
		u = 0;
		for(i=0; i<n; i++){
			scanf("%d%d", &k, &c);
			j = 1;
			while(j <= k)
			{
				v[++u] = c * j;
				k -= j; //剩余件数
				j<<=1;
			}
			if(k > 0) v[++u] = c * k; //余下的件数
		}
		for(i=1; i<=u; i++){
			for(j=check; j>=v[i]; j--){
				dp[j] = MAX(dp[j-v[i]] + v[i], dp[j]);
			}
		}
		printf("%d\n", dp[check]);
	}
	return 0;
}








  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值