POJ 2431 Expedition (贪心 + 优先级队列)

40 篇文章 0 订阅

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7696 Accepted: 2260

Description

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels. 

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop). 

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000). 

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop. 

* Line N+2: Two space-separated integers, L and P

Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

Hint

INPUT DETAILS: 

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively. 

OUTPUT DETAILS: 

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.

Source




题意:以汽车要行驶距离L的路程,路上有n个加油站,车从起点出发,在起点时,车上有汽油容量为p,已知单位距离1,就会消耗汽油1,已知n个加油站距离终点的距离和各个加油站可以加的油量,然后问最少需要加多少次油可以到达终点,若不能到达终点,输出“-1”。


解析:按照贪心的思想,我们肯定是尽可能的把油用完了再加,但是每个加油站的加油量有区别,这样就不能简单的贪心了。我们可以这样看,由于不知道什么时候加最合适,所以我们可以先把那些途经的加油站的油量全部放到优先级队列里,到后来需要的时候再加上,就相当于是经过那个站的时候把油给加上了,效果是一样的。这样就可以了,每次加的都是油量最大的,所以最后的加油次数就是最少的。




AC代码:

#include <cstdio>
#include <queue>
#include <iostream>
#include <algorithm>
using namespace std;
#define maxn 10002

int a[maxn], b[maxn];
struct node{ int a; int b; };        //加油站结构体,位置a,油量b
node m[maxn];

bool cmp(node x, node y){            //自己定义排序函数,先按位置升序排,相等时再按油量降序
    if(x.a == y.a) return x.b > y.b;
    return x.a < y.a;
}

int main(){
    #ifdef sxk
        freopen("in.txt", "r", stdin);
    #endif //sxk

    int n, l, p;
    while(scanf("%d", &n)!=EOF){
        for(int i=0; i<n; i++) scanf("%d%d", &m[i].a, &m[i].b);
        scanf("%d%d", &l, &p);
        for(int i=0; i<n; i++) m[i].a = l - m[i].a;          //处理读入的数据,将位置转化为据起点的位置
        m[n].a = l;               //方便起见,把终点也看作一个加油站
        m[n].b = 0;
        n ++;

        sort(m, m+n, cmp);                  //加油站按位置排序
        priority_queue<int> q;
        int flag = 1;
        int ans = 0, pos = 0, tank = p;     //加油次数ans,车的位置pos,车上剩余油量tank
        for(int i=0; i<n; i++){
            int d = m[i].a - pos;           //接下来要行进的距离
            while(tank < d){                //不断加油,直到油量足够行驶到下一个加油站
                if(q.empty()){              //未到加油站就没油了,代表不能完成任务了
                    flag = 0;
                    break;
                }
                tank += q.top();
                q.pop();
                ans ++;
            }
            if(!flag) break;
            tank -= d;
            pos = m[i].a;
            q.push(m[i].b);                 //将途经加油站的油量放入优先级队列
        }
        printf("%d\n", flag ? ans : -1);
    }
    return 0;
}


PS:优先级队列(priority_queue)很神奇,很好用,内部用堆实现的,所以时间复杂度还是很优的~~~



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值