弱校联萌十一大决战之强力热身 A. Easy Math (水)

5 篇文章 0 订阅

A. Easy Math
Time Limit: 2000msMemory Limit: 65536KB 64-bit integer IO format: %lld Java class name: Main
Submit Status
Given n integers a1,a2,…,an, check if the sum of their square root √a1+√a2+⋯+√an is a integer.
Input
The input consists of multiple tests. For each test:

The first line contains 1 integer n (1≤n≤105).
The second line contains n integers a1,a2,…,an (0≤ai≤109).


Output
For each test, write ‘‘Yes′′ if the sum is a integer, or ‘‘No′′ otherwise.


Sample Input
2
1 4
2
2 3
Sample Output
Yes
No




解析:只要有一个不是平方根,结果就不是整数




AC代码:

#include <bits/stdc++.h>
using namespace std;

int main(){
    #ifdef sxk
        freopen("in.txt", "r", stdin);
    #endif // sxk
    int n, x;
    while(scanf("%d", &n) == 1){
        int tg = 1;
        for(int i=0; i<n; i++){
            scanf("%d", &x);
            if(tg && (int)sqrt(x)*(int)sqrt(x) != x) tg = 0;
        }
        puts(tg ? "Yes" : "No");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值