hdu1061

Rightmost Digit
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=1061

Problem Description
Given a positive integer N, you should output the most right digit of N^N.


Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).


Output
For each test case, you should output the rightmost digit of N^N.


Sample Input

4




Sample Output

6

Hint

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.





解题思路:

       题意是求n ^ n 的最后一位,也就是最后结果求余10。

       首先来说你不能用先算完n ^ n的结果然后对10求余这种常规思路,因为n 的范围太大,可能__int64都存不下,所以用数论

知识,每步都求余10;接下来还是数据溢出的问题,因为中间存乘方结果时那个数很大,所以开成__int64存中间结果;最后注

意下奇偶的情况,奇数的话再乘次本身再对10取余。

       总结起来,温习了分治思想。




完整代码:

#include <functional>
#include <algorithm>
#include <iostream>
#include <fstream>
#include <sstream>
#include <iomanip>
#include <numeric>
#include <cstring>
#include <climits>
#include <cassert>
#include <complex>
#include <cstdio>
#include <string>
#include <vector>
#include <bitset>
#include <queue>
#include <stack>
#include <cmath>
#include <ctime>
#include <list>
#include <set>
#include <map>
using namespace std;

#pragma comment(linker, "/STACK:102400000,102400000")

typedef long long LL;
typedef double DB;
typedef unsigned uint;
typedef unsigned long long uLL;

/** Constant List .. **/ //{

const int MOD = int(1e9)+7;
const int INF = 0x3f3f3f3f;
const LL INFF = 0x3f3f3f3f3f3f3f3fLL;
const DB EPS = 1e-9;
const DB OO = 1e20;
const DB PI = acos(-1.0); //M_PI;
int k;

__int64 solve(int n)
{
    if(n == 0)
        return 1;
    __int64 sum = 1;
    __int64 tmp = solve(n / 2) % 10 ;
    sum = tmp * tmp % 10;
    if(n % 2)
        sum = sum * k % 10;
    return sum;
}


int main()
{
    #ifdef DoubleQ
    freopen("in.txt","r",stdin);
    #endif
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        scanf("%d",&n);
        k = n;
        printf("%I64d\n",solve(n));
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值