hdu 2126 Buy the souvenirs(求方案数的背包)

Problem Description
When the winter holiday comes, a lot of people will have a trip. Generally, there are a lot of souvenirs to sell, and sometimes the travelers will buy some ones with pleasure. Not only can they give the souvenirs to their friends and families as gifts, but also can the souvenirs leave them good recollections. All in all, the prices of souvenirs are not very dear, and the souvenirs are also very lovable and interesting. But the money the people have is under the control. They can’t buy a lot, but only a few. So after they admire all the souvenirs, they decide to buy some ones, and they have many combinations to select, but there are no two ones with the same kind in any combination. Now there is a blank written by the names and prices of the souvenirs, as a top coder all around the world, you should calculate how many selections you have, and any selection owns the most kinds of different souvenirs. For instance:



And you have only 7 RMB, this time you can select any combination with 3 kinds of souvenirs at most, so the selections of 3 kinds of souvenirs are ABC (6), ABD (7). But if you have 8 RMB, the selections with the most kinds of souvenirs are ABC (6), ABD (7), ACD (8), and if you have 10 RMB, there is only one selection with the most kinds of souvenirs to you: ABCD (10).

Input
For the first line, there is a T means the number cases, then T cases follow.
In each case, in the first line there are two integer n and m, n is the number of the souvenirs and m is the money you have. The second line contains n integers; each integer describes a kind of souvenir.
All the numbers and results are in the range of 32-signed integer, and 0<=m<=500, 0<n<=30, t<=500, and the prices are all positive integers. There is a blank line between two cases.

Output
If you can buy some souvenirs, you should print the result with the same formation as “You have S selection(s) to buy with K kind(s) of souvenirs”, where the K means the most kinds of souvenirs you can buy, and S means the numbers of the combinations you can buy with the K kinds of souvenirs combination. But sometimes you can buy nothing, so you must print the result “Sorry, you can't buy anything.”

Sample Input
  
  
2 4 7 1 2 3 4 4 0 1 2 3 4

Sample Output
 
 
You have 2 selection(s) to buy with 3 kind(s) of souvenirs. Sorry, you can't buy anything. 题意: 现在给出钱,需要你计算能买最多东西的方式有几种,比如给你第一组数据,最多能买3种物品,1 2 3和1 2 4,即不超出背包容量由能买到最大的东西数量; 思路: 按01背包的方法,想要求出最优的方案不是难事,但现在要求的不是最优解,而是满足情况的最大方案,所以我们找到了状态转移方程式 dp[j][k]=dp[j][k]+dp[j-a[i]][k-1] 我们申请一个二维数组,dp[2][max],dp[0][max]初始为0,dp[1][max]初始为1; dp[0][]记录最大的购买量,dp[1][]记录最多的组合数; 代码:
#include<iostream>
#include<stdio.h>
#include<string>
#include<queue>
#include<string.h>
#include<cmath>
#include<algorithm>
#include<math.h>
using namespace std;
const int inf=0x3f3f3f3f;



int dp[2][5005],w[505];
int main()
{
    int t;
    int n,bag;
    cin>>t;
    while(t--)
    {
        cin>>n>>bag;
        for(int i=0;i<=bag;i++)
        {
            dp[0][i]=0;
            dp[1][i]=1;
        }
        for(int i=0;i<n;i++)
        {
            cin>>w[i];
        }
        for(int i=0;i<n;i++)
        {
            for(int j=bag;j>=w[i];j--)
            {
                if(dp[0][j-w[i]]+1>dp[0][j])
                {
                    dp[0][j]=dp[0][j-w[i]]+1;//dp[0][]放的是可以选择的最大物品数
                    dp[1][j]=dp[1][j-w[i]];//如果物品数加1那么还是上一种方案的次数,不会变
                }
                else if(dp[0][j]==dp[0][j-w[i]]+1)
                {
                    dp[1][j]+=dp[1][j-w[i]];//如果最大的物品总数一样那么把前面一种的物品的取值次数加上
                }
            }
        }
        int s=dp[0][bag],t=dp[1][bag];
        if(s==0)
            cout<<"Sorry, you can't buy anything."<<endl;
        else
             printf("You have %d selection(s) to buy with %d kind(s) of souvenirs.\n",t,s);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值