UVA 10341- Solve It(二分+精度求解方程值)

Problem F

Solve It

Input: standard input

Output: standard output

Time Limit: 1 second

Memory Limit: 32 MB

Solve the equation:
        p*e-xq*sin(x) + r*cos(x) + s*tan(x) + t*x2 + u = 0
        where 0 <= x <= 1.

Input

Input consists of multiple test cases and terminated by an EOF. Each test case consists of 6 integers in a single line: pqrst and u (where 0 <= p,r<= 20 and -20 <= q,s,t <= 0). There will be maximum 2100 lines in the input file.

Output

For each set of input, there should be a line containing the value of x, correct upto 4 decimal places, or the string "No solution", whichever is applicable.

Sample Input

0 0 0 0 -2 1
1 0 0 0 -1 2
1 -1 1 -1 -1 1

Sample Output

0.7071
No solution
0.7554

题意:给出p,q,r,s,t,u的值,根据方程式求出方程的近似解。

思路:因为方程是递减的,对于两个端点,如果f(0)<0或者是f(1)>0 ,则说明方程无解。取两个端点的中点mid 如果f(0)*f(mid)<0  ,说明方程的解在[0,mid]中,否则解在[mid,1]中,这样不断进行下去,区间会收敛于一点,即为最后的近似解

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <set>
#include <queue>
#include <stack>
#include <map>
using namespace std;
#define eps 1e-8
double p,q,r,s,t,u;
double Solve (double x)
{
    return p*exp(-x)+q*sin(x)+r*cos(x)+s*tan(x)+t*x*x+u;//exp(x) 指的是e的x次方。
}
int main()
{
    double left,right,mid;
    while(~scanf("%lf %lf %lf %lf %lf %lf",&p,&q,&r,&s,&t,&u)) {
        if(Solve(0)<0||Solve(1)>0)
            printf("No solution\n");
        else {
            left=0;
            right=1;
            while((right-left)>=eps) {
                mid=(left+right)/2;
                if(Solve(mid)<0)
                    right=mid;
                else
                    left=mid;
            }
            printf("%.4lf\n",mid);
        }
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Rocky0429

一块也是爱

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值