关闭

CoccoaPods 安装与使用

标签: cocoaPods
70人阅读 评论(0) 收藏 举报
分类:

我需要的三方库 cocoaPods 安装


AFNetworking


DKNightVersion


Masonry


MBProgressHUD


MJExtension


SDWebImage


Target Support Files



7.2以下版本安装好Ruby环境 之后再进行如下操作.


sudo gem install cocoapods

如果没有开vpn 可以切换Ruby镜像

gem sources --remove https://rubygems.org/

等有反应了在输入

gem sources -a https://ruby.taobao.org/

为了验证你的Ruby镜像是并且仅是taobao,可以用以下命令查看:

   $ gem sources -l

       只有在终端中出现下面文字才表明你上面的命令是成功的:

   *** CURRENT SOURCES ***

sudo gem install cocoa pods


https://ruby.taobao.org/



   $ sudo gem install cocoapods

等上十几秒钟,CocoaPods就可以在你本地下载并且安装好了,不再需要其他设置。

 cocoaPods的路径是在 ~/.cocoapods 我用来确认cocoa pods是否存在



在终端找到工程的文件夹


cd ( 去掉括号,此处拖入工程文件夹) 

vim Podfile


platform :ios, '7.0'   platform 是平台的意思

target :OnlyProject do     OnlyProject ===>这个是Target的名字  6.0版本以上要这么修改

pod 'AFNetworking', '~> 2.5.4'

pod 'SDWebImage', '~> 3.7.2'

pod 'MBProgressHUD', '~> 0.9.1'

pod 'iCarousel', '~> 1.8.1'

pod 'MJExtension', '~> 2.5.3'

pod 'Masonry', '~> 0.6.2'

pod 'DKNightVersion', '~> 0.8.1'

end   注意要填写end   

然后按esc   输入 :wq  回车

然后 pod install

0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:1332次
    • 积分:122
    • 等级:
    • 排名:千里之外
    • 原创:11篇
    • 转载:2篇
    • 译文:0篇
    • 评论:0条
    文章分类
    文章存档