HDU 5542 The Battle of Chibi(dp+树状数组)

The Battle of Chibi

Time Limit: 6000/4000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 2144    Accepted Submission(s): 759

Problem Description

Cao Cao made up a big army and was going to invade the whole South China. Yu Zhou was worried about it. He thought the only way to beat Cao Cao is to have a spy in Cao Cao's army. But all generals and soldiers of Cao Cao were loyal, it's impossible to convince any of them to betray Cao Cao.
So there is only one way left for Yu Zhou, send someone to fake surrender Cao Cao. Gai Huang was selected for this important mission. However, Cao Cao was not easy to believe others, so Gai Huang must leak some important information to Cao Cao before surrendering.
Yu Zhou discussed with Gai Huang and worked out N information to be leaked, in happening order. Each of the information was estimated to has ai value in Cao Cao's opinion.
Actually, if you leak information with strict increasing value could accelerate making Cao Cao believe you. So Gai Huang decided to leak exact M information with strict increasing value in happening order. In other words, Gai Huang will not change the order of the N information and just select M of them. Find out how many ways Gai Huang could do this.

Input

The first line of the input gives the number of test cases, T(1100) . T test cases follow.
Each test case begins with two numbers N(1N103) and M(1MN) , indicating the number of information and number of information Gai Huang will select. Then N numbers in a line, the ith number ai(1ai109) indicates the value in Cao Cao's opinion of the ith information in happening order.

Output

For each test case, output one line containing Case #x: y, where x is the test case number (starting from 1) and y is the ways Gai Huang can select the information.
The result is too large, and you need to output the result mod by 1000000007(109+7) .

Sample Input

 
 
2 3 2 1 2 3 3 2 3 2 1

Sample Output

 
 
Case #1: 3 Case #2: 0
Hint
In the first cases, Gai Huang need to leak 2 information out of 3. He could leak any 2 information as all the information value are in increasing order. In the second cases, Gai Huang has no choice as selecting any 2 information is not in increasing order.

Source

The 2015 China Collegiate Programming Contest



        按照惯例,比赛期间应该停止刷题……

        但是经过上次的失败经历我发现,手感这种东西还是很重要的,不然关键时候卡题……

        于是今晚重新刷一套CCPC,结果发现自己状态神勇,几乎是自己一个人在3小时10分钟内A了6题……虽说水题有好几道,但怎么说至少没有卡手,后面的这两道稍微算上中档题的dp也几乎是一次过样例。

        废话说多了,看看这道题。就是给你一个序列,问你长度为m的严格上升序列总共有多少种。方案数问题,dp也是很明显的,有转移方程dp[i][j]=Σdp[k][j-1],其中dp[i][j]表示以第i个数字为结尾,组成长度为j的严格上升序列的方案数,满足i<k且a[k]<a[i]。但是,也是很显然这个O(N^3)的方程对于这个数据范围来说太慢了,于是开始想办法优化。

        根据数据范围,此题有可能是O(N^2)或者O(N^2logN)级别的,注意到时间给了4s,所以最可能是O(N^2logN)级别。观察dp转移方程,我们可以看到,dp[i][j]只与dp数组的第j-1列相关。这意味着,我们可以考虑是否可以用前缀和或者说一段和的形式来转移。有由于有一个大小关系的限制,所以我们设置求和数组s[i][j]表示用离散化之后前i个数字,组成长度为j的严格上升序列的方案数。那么就有转移方程dp[i][j]=s[mp[a[i]]-1][j-1],其中mp[i]表示数字i离散化之后的序号。那么接下来我们看怎么维护这个s[i][j],由于每次更新dp数组,相应会改变s数组,而注意到dp[i][j]改变之后,前i个数字中,所有比a[i]大的长度为j的位置都需要修改,这样一个区间修改,自然而然的想到利用树状数组来处理。

        这样一来,整个复杂度O(N^2logN)和我们预期的一样,可以通过此题。具体见代码:

#include<bits/stdc++.h>
#define mod 1000000007
#define LL long long
#define N 1010
using namespace std;

int n,m,a[N],b[N],tot;
LL dp[N][N],c[N][N];
map<int,int> mp;

void init()
{
    mp.clear(); tot=0;
    memset(c,0,sizeof(c));
    memset(dp,0,sizeof(dp));
}

void change(int x,int y,LL d)
{
    for(int i=x;i<=tot;i+=(i&(-i)))
        c[i][y]=(c[i][y]+d)%mod;
}

LL sum(int x,int y)
{
    LL ans=0;
    for(int i=x;i>0;i-=(i&(-i)))
        ans=(ans+c[i][y])%mod;
    return ans;
}

int main()
{
    int T,TT=0;
    cin>>T;
    while(T--)
    {
        init();
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            b[i]=a[i];
        }
        sort(b+1,b+1+n);
        for(int i=1;i<=n;i++)
            if (!mp[b[i]]) mp[b[i]]=++tot;
        for(int i=1;i<=n;i++)
        {
            dp[i][1]=1;
            for(int j=2;j<=min(i,m);j++)
                dp[i][j]=sum(mp[a[i]]-1,j-1);
            for(int j=1;j<=min(i,m);j++)
                change(mp[a[i]],j,dp[i][j]);
        }
        LL ans=0;
        for(int i=m;i<=n;i++)
            ans=(ans+dp[i][m])%mod;
        printf("Case #%d: %I64d\n",++TT,ans);
    }
    return 0;
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值