HDOJ 1175连连看 (DFS)

Problem Description
“连连看”相信很多人都玩过。没玩过也没关系,下面我给大家介绍一下游戏规则:在一个棋盘中,放了很多的棋子。如果某两个相同的棋子,可以通过一条线连起来(这条线不能经过其它棋子),而且线的转折次数不超过两次,那么这两个棋子就可以在棋盘上消去。不好意思,由于我以前没有玩过连连看,咨询了同学的意见,连线不能从外面绕过去的,但事实上这是错的。现在已经酿成大祸,就只能将错就错了,连线不能从外围绕过。
玩家鼠标先后点击两块棋子,试图将他们消去,然后游戏的后台判断这两个方格能不能消去。现在你的任务就是写这个后台程序。
 

Input
输入数据有多组。每组数据的第一行有两个正整数n,m(0<n<=1000,0<m<1000),分别表示棋盘的行数与列数。在接下来的n行中,每行有m个非负整数描述棋盘的方格分布。0表示这个位置没有棋子,正整数表示棋子的类型。接下来的一行是一个正整数q(0<q<50),表示下面有q次询问。在接下来的q行里,每行有四个正整数x1,y1,x2,y2,表示询问第x1行y1列的棋子与第x2行y2列的棋子能不能消去。n=0,m=0时,输入结束。
注意:询问之间无先后关系,都是针对当前状态的!
 

Output
每一组输入数据对应一行输出。如果能消去则输出"YES",不能则输出"NO"。
 

Sample Input
  
  
3 4 1 2 3 4 0 0 0 0 4 3 2 1 4 1 1 3 4 1 1 2 4 1 1 3 3 2 1 2 4 3 4 0 1 4 3 0 2 4 1 0 0 0 0 2 1 1 2 4 1 3 2 3 0 0
 

Sample Output
  
  
YES NO NO NO NO YES
//
//  main.cpp
//  连连看
//
//  Created by 张嘉韬 on 16/3/23.
//  Copyright © 2016年 张嘉韬. All rights reserved.
//

#include <iostream>
#include <cstring>
using namespace std;
int n,m,map[1010][1010],sx,sy,ex,ey,a[100000],flag,con[1010][1010];
int dx[]={-1,1,0,0};
int dy[]={0,0,-1,1};
void init()
{
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=m;j++)
        {
            map[i][j]=con[i][j];
        }
    }
}
void print(int i,int k)
{
    cout<<i<<" "<<k<<endl;
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=m;j++)
        {
            cout<<map[i][j]<<" ";
        }
        cout<<endl;
    }
    cout<<endl;
}
void dfs(int counter,int x,int y,int k)
{
    if(counter>2) return ;
    if(flag) return ;
    int tempx,tempy,tempc;
    tempc=counter;
    for(int i=0;i<=3;i++)
    {
        if(counter>=2)
        {
            if(i!=a[k-1])
                continue;
        }
        tempx=x+dx[i];
        tempy=y+dy[i];
        if(tempx>=1&&tempx<=n&&tempy>=1&&tempy<=m&&map[tempx][tempy]==0)
        {
            map[tempx][tempy]=-1;
            if(a[k]!=a[k-1]) counter++;
            //print(i,k);
            if(tempx==ex&&tempy==ey&&counter<=2)
            {
                flag=1;
                return;
            }
            else dfs(counter,tempx,tempy,k+1);
            map[tempx][tempy]=0;
            counter=tempc;
        }
    }
}
int main(int argc, const char * argv[]) {
    //freopen("/Users/zhangjiatao/Desktop/input.txt","r",stdin);
    while(scanf("%d%d",&n,&m)==2)
    {
        int q;
        if(n==0&&m==0) return 0;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                cin>>con[i][j];
            }
        }
        cin>>q;
        for(int t=1;t<=q;t++)
        {
            init();
            flag=0;
            memset(a,0,sizeof(a));
            a[0]=-1;
            cin>>sx>>sy>>ex>>ey;
            if(map[sx][sy]!=map[ex][ey]||map[sx][sy]==0||map[ex][ey]==0)
            {
                cout<<"NO"<<endl;
                continue;
            }
            map[ex][ey]=0;
            //cout<<t<<" "<<"("<<sx<<","<<sy<<")"<<endl;
            dfs(-1,sx,sy,1);
            if(flag) cout<<"YES"<<endl;
            else cout<<"NO"<<endl;
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值