UVa 156 (stl map的使用)

11 篇文章 0 订阅
8 篇文章 0 订阅

 
一。map

map就是从键(key)到值(value)的映射,重载了[]所以可以认为是高级版的数组,常用的一些操作如下:

头文件:#include<map>

定义:map <类型一(key),类型二(value)> name  key称为map的frist,value称为map的second。

初始化:name.clear();

二.题目

 

Ananagrams

Most crossword puzzle fans are used to anagrams--groups of words with the same letters in different orders--for example OPTS, SPOT, STOP, POTS and POST. Some words however do not have this attribute, no matter how you rearrange their letters, you cannot form another word. Such words are called ananagrams, an example is QUIZ.

Obviously such definitions depend on the domain within which we are working; you might think that ATHENE is an ananagram, whereas any chemist would quickly produce ETHANE. One possible domain would be the entire English language, but this could lead to some problems. One could restrict the domain to, say, Music, in which case SCALE becomes a relative ananagram (LACES is not in the same domain) but NOTE is not since it can produce TONE.

Write a program that will read in the dictionary of a restricted domain and determine the relative ananagrams. Note that single letter words are, ipso facto, relative ananagrams since they cannot be ``rearranged'' at all. The dictionary will contain no more than 1000 words.

Input

Input will consist of a series of lines. No line will be more than 80 characters long, but may contain any number of words. Words consist of up to 20 upper and/or lower case letters, and will not be broken across lines. Spaces may appear freely around words, and at least one space separates multiple words on the same line. Note that words that contain the same letters but of differing case are considered to be anagrams of each other, thus tIeD and EdiT are anagrams. The file will be terminated by a line consisting of a single #.

Output

Output will consist of a series of lines. Each line will consist of a single word that is a relative ananagram in the input dictionary. Words must be output in lexicographic (case-sensitive) order. There will always be at least one relative ananagram.

Sample input

ladder came tape soon leader acme RIDE lone Dreis peat
 ScAlE orb  eye  Rides dealer  NotE derail LaCeS  drIed
noel dire Disk mace Rob dries
#

Sample output

Disk
NotE
derail
drIed
eye
ladder
soon

三.代码

#include <iostream>
#include <cstdio>
#include <map>
#include <algorithm>
#include <vector>
#include <cctype>
using namespace std;
vector <string> words;
map<string,int> counter;
int num;
string repr(const string& temp)
{
	string r=temp;
	for(int i=0;i<temp.length();i++)
	{
		r[i]=tolower(temp[i]);
	}
	sort(r.begin(),r.end());
	return r;
}
int main()
{
	//freopen("input.txt","r",stdin);
	counter.clear();
	string temp;
	num=0;
	while(cin>>temp)
	{
		if(temp[0]=='#') break;
		words.push_back(temp);
		//cout<<temp<<" ";
		string r;
		r=repr(temp);
		counter[r]++;
		//cout<<r<<" "<<counter[r]<<endl;
	}
	vector <string> ans;
	for(int i=0;i<=words.size()-1;i++)
	{		
		if(counter[repr(words[i])]==1)	ans.push_back(words[i]);
	}
	sort(ans.begin(),ans.end());
	for(int i=0;i<ans.size();i++)
	{
		cout<<ans[i]<<endl;
	}
	return 0;
}

三.总结

这个程序里面用到了大小写转化(大写转化成小写)函数tolower(),函数的头文件为cctype,特别注意,最好先将要转换字符串保存在希望转换完成成的变量里,否则会出现未知的错误,用法最好标准一些。
string repr(const string& temp)
{
	string r=temp;
	for(int i=0;i<temp.length();i++)
	{
		r[i]=tolower(temp[i]);
	}
	sort(r.begin(),r.end());
	return r;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值