kuangbin求带飞DP1 Doing HomeWork(动态规划+状态压缩)

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score. 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. 
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject's name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject's homework). 

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier. 

Output

For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one. 

Sample Input

2
3
Computer 3 3
English 20 1
Math 3 2
3
Computer 3 3
English 6 3
Math 6 3

Sample Output

2
Computer
Math
English
3
Computer
English
Math

总结:

啊!终于切掉了心头大恨,太tm爽了,这道题困扰我很长时间,一开始思考不说,看了题解以后也用了很长时间去搞这道题,所以说,就算有题解也还是要考自己的脑子去思考实现这样更快!这道题很有意思,大体思路就是用二进制表示每个作业的完成状态,因为作业的数量不多,所以我们可以用一个数字来表示出当前的所有作业的完成状态,我们把这样的一种状态用一个数来表示,然后我们遍历所有状态,然后在每个状态中,找到当前状态中哪个作业是完成的了,那么就可能是这个状态的前驱状态,我们找到扣分最小的状态当作前驱状态就可以了
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
const int inf=99999999;
const int maxn=20;
int a[maxn];
struct work
{
    char name[200];
    int cost ;
    int deadline;
}works[maxn];
struct Node
{
    int day;
    int reduce ;
    int pre;
    int fin;
}f[1<<maxn];
int cmp(work a,work b)
{
    return a.name>b.name;
}
int main()
{
    //freopen("/Users/zhangjiatao/Documents/暑期训练/input.txt","r",stdin);
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n,end;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%s%d%d",works[i].name,&works[i].deadline,&works[i].cost);
        }
        
//        for(int i=0;i<n;i++)
//        {
//            cout<<works[i].name<<" ";
//        }
//        cout<<endl;
//        //sort(works+0,works+n,cmp);
//        
//        for(int i=0;i<n;i++)
//        {
//            cout<<works[i].name<<" ";
//        }
//        cout<<endl;
        
        f[0].day=0;
        f[0].reduce=0;
        f[0].fin=-1;
        f[0].pre=-1;
        end=1<<n;
        for(int i=1;i<end;i++)
        {
            int minimum=inf;
            for(int j=n-1;j>=0;j--)
            {
                int tem=1<<j;
                if(i&tem)
                {
                    int past=i-tem;
                    int day=f[past].day+works[j].cost;
                    int reduce=f[past].day+works[j].cost-works[j].deadline;
                    if(reduce<0) reduce=0;
                    reduce+=f[past].reduce;
                    
                    if(reduce<minimum)
                    {
                        minimum=reduce;
                        f[i].day=day;
                        f[i].reduce=reduce;
                        f[i].pre=past;
                        f[i].fin=j;
                    }
                }
            }
            //cout<<f[i].fin<<" ";
        }
        int p=n,s=end-1;
        a[p]=f[s].fin;
        while(f[s].pre!=-1)
        {
            p--;
            s=f[s].pre;
            a[p]=f[s].fin;
        }
        printf("%d\n",f[end-1].reduce);
        for(int i=1;i<=n;i++)
        {
            cout<<works[a[i]].name<<endl;
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值