poj 1014 多重背包问题

20 篇文章 0 订阅

http://poj.org/problem?id=1014

Description

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input

Each line in the input file describes one collection of marbles to be divided. The lines contain six non-negative integers n1 , . . . , n6 , where ni is the number of marbles of value i. So, the example from above would be described by the input-line "1 0 1 2 0 0". The maximum total number of marbles will be 20000. 
The last line of the input file will be "0 0 0 0 0 0"; do not process this line.

Output

For each collection, output "Collection #k:", where k is the number of the test case, and then either "Can be divided." or "Can't be divided.". 
Output a blank line after each test case.

Sample Input

1 0 1 2 0 0 
1 0 0 0 1 1 
0 0 0 0 0 0 

Sample Output

Collection #1:
Can't be divided.

Collection #2:
Can be divided.
题意:有1~6,6种价值的石子数量若干,问是否可以把石子平均分成两部分价值相等。

/**
所有石子的价值sum,若sum为奇数,无解;否则sum/2为背包的容量,若最后背包可以获得sum/2的价值,就可以平分开来。数据较大,采用二进制形式
*/
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
using namespace std;
const int N=60050;
int c[N],w[N],f[N];
int a[8];

int pow(int a)
{
    int ret=1;
    while(a--)
        ret<<=1;
    return ret;
}

int main()
{
    int tt=0;
    while(~scanf("%d",&a[1]))
    {
        int num=0;
        int sum=a[1];
        if(a[1]==0)
            num++;
        for(int i=2; i<=6; i++)
        {
            scanf("%d",&a[i]);
            sum+=a[i]*i;
            if(a[i]==0)
                num++;
        }
        if(num==6)
            break;
        int nn=0;
        for(int i=1; i<=6; i++)
        {
            int k=0;
            while(1)
            {
                if(a[i]-pow(k+1)+1<=0)
                    break;
                k++;
            }
            int cnt;
            for(int j=0; j<k; j++)
            {
                cnt=pow(j);
                nn++;
                c[nn]=i*cnt;
                w[nn]=i*cnt;
            }
            nn++;
            cnt=a[i]-pow(k)+1;
            c[nn]=i*cnt;
            w[nn]=i*cnt;
        }
        printf("Collection #%d:\n",++tt);
        if(sum%2)
        {
            printf("Can't be divided.\n\n");
            continue;
        }
        sum/=2;
        memset(f,0,sizeof(f));
        for(int i=1; i<=nn; i++)
            for(int j=sum; j>=c[i]; j--)
                f[j]=max(f[j],f[j-c[i]]+w[i]);
        if(f[sum]!=sum)
            printf("Can't be divided.\n\n");
        else
            printf("Can be divided.\n\n");
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值