poj 2488 A Knight's Journey

A Knight's Journey
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 28501 Accepted: 9745

Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source

TUD Programming Contest 2005, Darmstadt, Germany

好久没做dfs,再加上突然搞出来一个字典序,把爹做出翔

其实大家不要被什么字典序唬住了,字典序方面只要处理一些细节就好,主要的还是dfs,相当简单的dfs,全题个人认为有两个比较值得学习的地方,详见代码:

#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int dir[8][2]={{-2,-1},{-2,1},{-1,-2},{-1,2},{1,-2},{1,2},{2,-1},{2,1}};
///本题第一个撸点,因为题目要求要按照字典序输出,所以要先搜索字典序较小的点,即在使坐标第一个值尽量小的情况下再使第二个坐标尽量小。
int p, q;
bool used[100][100];
int path[100][100];
bool flag;
bool check(int x, int y)
{
	if(x > 0 && y > 0 && x <= p && y <= q && !used[x][y] && !flag)
		return 1;
	return 0;
}
void dfs(int x, int y, int step)
{
	path[step][0] = x;
	path[step][1] = y;
	if(step == p*q)
	{
		///printf("huang\n");
		flag = 1;
		return;
	}
	for(int i=0; i<8; ++i)
	{
		int xx = x + dir[i][1];
		int yy = y + dir[i][0];
		if(check(xx , yy))
		{
			used[xx][yy] = 1;
			dfs(xx, yy, step+1);
			used[xx][yy] = 0;
		}
	}
}
int main()
{
	int cnt, T;
	scanf("%d", &T);
	cnt = 0;
	while(T--)
	{
		cnt++;
		flag = 0;
		scanf("%d%d", &p, &q);
		memset(used, 0, sizeof(used));
		used[1][1]=1;
		dfs(1, 1, 1);
		/**本题第二个撸点,因为如果棋子能够走遍整个棋盘,那么一定能走到A1,
		那么根据从字典序较小的点开始搜索的规律,所有情况都应该从A1开始搜索**/
		printf("Scenario #%d:\n", cnt);
		if(!flag) printf("impossible\n");
		else if(flag)
		{
			for(int i=1; i<=p*q; ++i)
				printf("%c%d", path[i][1]- 1 + 'A', path[i][0]);
			printf("\n");
		}
		if(T != 0) printf("\n");
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值