1034. Head of a Gang (30)

One way that the police finds the head of a gang is to check people's phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls made between the two persons. A "Gang" is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threshold K. In each gang, the one with maximum total weight is the head. Now given a list of phone calls, you are supposed to find the gangs and the heads.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers N and K (both less than or equal to 1000), the number of phone calls and the weight threthold, respectively. Then N lines follow, each in the following format:

Name1 Name2 Time

where Name1 and Name2 are the names of people at the two ends of the call, and Time is the length of the call. A name is a string of three capital letters chosen from A-Z. A time length is a positive integer which is no more than 1000 minutes.

Output Specification:

For each test case, first print in a line the total number of gangs. Then for each gang, print in a line the name of the head and the total number of the members. It is guaranteed that the head is unique for each gang. The output must be sorted according to the alphabetical order of the names of the heads.

Sample Input 1:
8 59
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10
Sample Output 1:
2
AAA 3
GGG 3
Sample Input 2:
8 70
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10
Sample Output 2:
0
考察并查集的使用
#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
#include <cstring>
#include <map>
using namespace std;
const int maxn = 2005;
int ufs[maxn],tottime[maxn],indtime[maxn];
vector<int> mem[maxn];
map<string,int> str2int;
map<int,string> int2str;
int id = 0;
int s2i(const string &s){
	auto itr = str2int.find(s);
	if(itr == str2int.end()){
		int t = id++;
		int2str[t] = s;
		return str2int[s] = t;
	}return itr->second;
}
string i2s(int x){return int2str[x];}
int find_set(int x){return x == ufs[x] ? x :ufs[x] = find_set(ufs[x]);}
bool cmp(int x,int y){return indtime[x] < indtime[y];}
int n,k;
int main(){
	cin>>n>>k;
	string a,b;int c,d,e;
	for(int i=0;i<maxn;i++){ufs[i] = i;tottime[i] = 0;mem[i].push_back(i);}
	for(int i=0;i<n;i++){
		cin>>a>>b>>e;
		c = s2i(a);d = s2i(b);
		indtime[c] += e;indtime[d] += e;
		int r1 = find_set(c),r2 = find_set(d);
		if(r1 != r2){
			ufs[r1] = r2;
			tottime[r2] = tottime[r1] + tottime[r2] + e;
			mem[r2].insert(mem[r2].end(),mem[r1].begin(),mem[r1].end());
		}else
			tottime[r1] += e;
	}
	vector<int> gangs;
	map<string,int> res;
	for(int i=0;i<maxn;i++)if(ufs[i] == i && mem[i].size() > 2 && tottime[i] > k)gangs.push_back(i);
	cout<<gangs.size()<<endl;
	for(int i=0;i<gangs.size();i++){
		int t = max_element(mem[gangs[i]].begin(),mem[gangs[i]].end(),cmp) - mem[gangs[i]].begin();
		res[i2s(mem[gangs[i]][t])] = mem[gangs[i]].size();
	}
	for(auto itr = res.begin();itr != res.end();++itr)cout<<itr->first<<" "<<itr->second<<endl;
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值