hdu 3333 Turing Tree ( 树状数组)

 

使用树状数组,一边插入ai,一边更新区间右值为i的询问,同时用map标记ai是否重复过,如果是,则在上个位置把它置零。

 

Turing Tree

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3067    Accepted Submission(s): 1042


Problem Description
After inventing Turing Tree, 3xian always felt boring when solving problems about intervals, because Turing Tree could easily have the solution. As well, wily 3xian made lots of new problems about intervals. So, today, this sick thing happens again...

Now given a sequence of N numbers A1, A2, ..., AN and a number of Queries(i, j) (1≤i≤j≤N). For each Query(i, j), you are to caculate the sum of distinct values in the subsequence Ai, Ai+1, ..., Aj.
 


 

Input
The first line is an integer T (1 ≤ T ≤ 10), indecating the number of testcases below.
For each case, the input format will be like this:
* Line 1: N (1 ≤ N ≤ 30,000).
* Line 2: N integers A1, A2, ..., AN (0 ≤ Ai ≤ 1,000,000,000).
* Line 3: Q (1 ≤ Q ≤ 100,000), the number of Queries.
* Next Q lines: each line contains 2 integers i, j representing a Query (1 ≤ i ≤ j ≤ N).
 


 

Output
For each Query, print the sum of distinct values of the specified subsequence in one line.
 


 

Sample Input
  
  
2 3 1 1 4 2 1 2 2 3 5 1 1 2 1 3 3 1 5 2 4 3 5
 


 

Sample Output
  
  
1 5 6 3 6

 

 

#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#include<stdio.h>
#include<algorithm>
#include<cmath>
#include<set>
#include<map>
#include<queue>
using namespace std;

#define inf 0x3f3f3f3f
#define eps 1e-8
#define maxn 30005
#define maxe 100006
#define FOR(i,s,t) for(int i = s; i < t; i++ )
#define LL long long int
#define ULL unsigned long long
#define pii pair<int,int>

const int mod = 10007;
//FILE *fin = fopen( "data.in","r" );
LL sum[maxn],a[maxn],ans[maxe];
int n,m;
map < LL ,int > vis;

struct que {
	int l,r,id;
	bool operator < ( const que& b ) const {
		return r < b.r;
	}
}q[maxe];

int lowbit ( int x ){
	return x & (-x);
}

void add ( int i, LL v ){
	while( i <= n ){
		sum[i] += v;
		i += lowbit(i);
	}
}

LL getsum ( int end ){
	LL s = 0;
	while( end ){
		s += sum[end];
		end -= lowbit(end);
	}
	return s;
}

int main (){
	int t;
	cin>>t;
	while( t-- ){
		vis.clear ();
		memset(sum,0,sizeof(sum));
		scanf("%d",&n);
		FOR(i,0,n)
			scanf("%I64d",&a[i]);
		scanf("%d",&m);
		FOR(i,0,m)
			scanf("%d%d",&q[i].l,&q[i].r), q[i].id = i;
		sort(q,q+m);
		int j = 0;
		FOR(i,0,n){
			add(i+1,a[i]);
			if( vis[a[i]] > 0 )
				add(vis[a[i]],-a[i]);
			vis[a[i]] = i+1;
			while( j < m && q[j].r == i+1 ){
				ans[q[j].id] = getsum(q[j].r) - getsum(q[j].l-1);
				j++;
			}
		}
		FOR(i,0,m)
			printf("%I64d\n",ans[i]);
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值