POJ2487Farey Sequence(欧拉函数&&法雷级数)

题目链接:http://poj.org/problem?id=2478

Description

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are 
F2 = {1/2} 
F3 = {1/3, 1/2, 2/3} 
F4 = {1/4, 1/3, 1/2, 2/3, 3/4} 
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5} 

You task is to calculate the number of terms in the Farey sequence Fn.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 10 6). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn. 

Sample Input

2
3
4
5
0

Sample Output

1
3
5
9
题目要求是求出Fn的元素个数,由法雷级数的定义可知

Fn 是由一系列的不能约分的分数a/b(0<a<b<=n&&gcd(a,b)=1)按递增顺序排列组合而成

因此我们很容易的就可以知道 第N项的元素个数为 2,3.。。。。n的欧拉函数值的和

#include <iostream>
#include <cstdio>
using namespace std;
typedef long long LL;
const int N = 1000001;
LL oular[N];
void phi()
{
    for(int i=1;i<N;i++)   oular[i]=i;
    for(int i=2;i<N;i+=2)   oular[i]/=2;
    for(int i=3;i<N;i+=2){
        if(oular[i]==i){
            for(int j=i;j<N;j+=i)
                oular[j]=oular[j]/i*(i-1);
        }
    }
    for(int i=3;i<N;i++)
        oular[i]+=oular[i-1];
}
int main()
{
    phi();
    int n;
    while(~scanf("%d",&n)&&n){
        printf("%I64d\n",oular[n]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值