HDU 1041 Computer Transformation 【找规律+高精度】

Computer Transformation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6045    Accepted Submission(s): 2208


Problem Description
A sequence consisting of one digit, the number 1 is initially written into a computer. At each successive time step, the computer simultaneously tranforms each digit 0 into the sequence 1 0 and each digit 1 into the sequence 0 1. So, after the first time step, the sequence 0 1 is obtained; after the second, the sequence 1 0 0 1, after the third, the sequence 0 1 1 0 1 0 0 1 and so on.

How many pairs of consequitive zeroes will appear in the sequence after n steps?
 

Input
Every input line contains one natural number n (0 < n ≤1000).
 

Output
For each input n print the number of consecutive zeroes pairs that will appear in the sequence after n steps.
 

Sample Input
  
  
2 3
 

Sample Output
  
  
1 1
 

Source
 

/*题解:
    找规律,满足a[i]=a[i-1]+2*a[i-2]; 
由于数据范围很大,需要用大数解决。 
*/

#include<cstdio>
#include<cstring>
int a[1002][1010];
void fun(int n)
{
    int i,j,c,ans,d=1;
    a[0][0]=0;
    a[1][0]=0;
    a[2][0]=1;
    a[3][0]=1;
    for(i=4; i<=n; i++)
    {
        c=0;
        for(j=0; j<d; j++)
        {
            ans=a[i-1][j]+2*a[i-2][j]+c;
            a[i][j]=ans%10;
            c=ans/10;
        }
        while(c)
        {
            a[i][d++]=c%10;
            c/=10;
        }
    }
    for(i=d-1; i>=0; i--)
        printf("%d",a[n][i]);
    printf("\n");
}

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        memset(a,0,sizeof(a));
        fun(n);
    }
    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值