BZOJ 1622: [Usaco2008 Open]Word Power 名字的能量

Description

    约翰想要计算他那N(1≤N≤1000)只奶牛的名字的能量.每只奶牛的名字由不超过1000个字待构成,没有一个名字是空字体串,  约翰有一张“能量字符串表”,上面有M(1≤M≤100)个代表能量的字符串.每个字符串由不超过30个字体构成,同样不存在空字符串.一个奶牛的名字蕴含多少个能量字符串,这个名字就有多少能量.所谓“蕴含”,是指某个能量字符串的所有字符都在名字串中按顺序出现(不一定一个紧接着一个).
    所有的大写字母和小写字母都是等价的.比如,在贝茜的名字“Bessie”里,蕴含有“Be”
“sI”“EE”以及“Es”等等字符串,但不蕴含“lS”或“eB”.请帮约翰计算他的奶牛的名字的能量.

Input

    第1行输入两个整数N和M,之后N行每行输入一个奶牛的名字,之后M行每行输入一个能量字符串.

Output

 
    一共N行,每行一个整数,依次表示一个名字的能量.

Sample Input

5 3
Bessie
Jonathan
Montgomery
Alicia
Angola
se
nGo
Ont

INPUT DETAILS:

There are 5 cows, and their names are "Bessie", "Jonathan",
"Montgomery", "Alicia", and "Angola". The 3 good strings are "se",
"nGo", and "Ont".

Sample Output

1
1
2
0
1

OUTPUT DETAILS:

"Bessie" contains "se", "Jonathan" contains "Ont", "Montgomery" contains
both "nGo" and "Ont", Alicia contains none of the good strings, and
"Angola" contains "nGo".

题解

模拟,常用字符的ASCII码还是要记住为好。

#include<cstdio> 
#include<iostream> 
#include<cstring> 
#include<cstdlib> 
#include<cmath> 
#include<algorithm> 
using namespace std; 
int n,m,l[1010],ct[1010]; 
char ch[1010][1010],a[110]; 
void init() 
{ 
    scanf("%d%d",&n,&m); 
    int i; 
    for(i=1;i<=n;i++) 
       {scanf("%s",ch[i]); 
        l[i]=strlen(ch[i]); 
       } 
} 
void doit() 
{ 
    scanf("%s",a); 
    int i,j,k,ll; 
    ll=strlen(a); 
    for(i=1;i<=n;i++) 
       {j=0,k=0; 
        while(j<l[i]&&k<ll) 
           {if(ch[i][j]<'a') ch[i][j]=(char)ch[i][j]+32; 
            if(a[k]<'a') a[k]=(char)a[k]+32; 
            if(ch[i][j]==a[k]) 
               {j++; k++;} 
            else j++; 
           } 
        if(k==ll) ct[i]++; 
        /*for(j=0;j<l[i];j++) printf("%c",ch[i][j]); 
        printf("\n");*/
       } 
} 
int main() 
{ 
    init(); 
    int i; 
    for(i=1;i<=m;i++) doit(); 
    for(i=1;i<=n;i++) printf("%d\n",ct[i]); 
    return 0; 
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值