POJ-2199 Rate of Return【二分求解一元高次方程】

Jill has been investing in a mutual fund for a while. Since her income has varied, the amount of money she has added to the investment has varied, and she hasn’t always added to the investment at regular intervals. Nevertheless, she does have a complete record of the amounts she has invested, and the dates of those investments.
Periodically Jill gets a report that indicates the total value of her investment. She wonders if she would have done better by investing her money in a savings account that pays a fixed interest rate. But to determine the answer to this question, she needs to know what the equivalent interest rate would have been paid on the mutual fund, had it paid a fixed rate. You are going to help her. 
For simplicity we will assume that Jill added money to her mutual fund only at the beginning of a month, and that all months have the same length. We will further assume that the interest she would have been paid had she invested in a savings account would have been paid at the end of the month, and would have been compounded monthly. 
Let's consider a simple example. Suppose Jill invested $100 at the beginning of January and another $100 in March. At the end of April she finds that the value of her mutual fund is $210. If the equivalent fixed monthly interest rate was i, then we know that at the end of January the value would have been 100 * (1 + i). At the end of February the value would have been 100 * (1 + i) * (1 + i), or 100 * (1 + i) 2. At the end of March, the value would have been 100 * (1 + i)  3 + 100 * (1 + i), and at the end of April, the value would have been 100 * (1 + i)  4 + 100 * (1 + i) 2. So the question to be answered in this case is this: what is the value of i such that 100 * (1 + i)  4 + 100 * (1 + i)  2 = 210? The answer for this case is close to 0.016351795234.
Input
The input will contain multiple cases. The input for each case will begin with an integer N (no larger than 12) that indicates the number of times Jill invested in her mutual fund. This will be followed by N + 1 pairs, each pair containing an integer and a real number. The integer represents a month number (1 or larger) and the real number represents a dollar amount. The first N pairs give the month and amount of each of Jill’s N investments in the mutual fund, and the last pair indicates the value of the investment at the end of the specified month. There will be one or more whitespace characters (blanks, tabs, and/or ends of lines) between the input numbers. You may assume that the month numbers are given in ascending order. 
Input for the last case will be followed by a single integer –1.
Output
For each case, display the case number (they start with 1 and increase sequentially) and the equivalent fixed monthly interest rate Jill's mutual fund would have paid. Display this number with five fractional digits, rounded to the nearest decimal place. You may assume the interest rate will be no less than 0 and no larger than 1. Separate the output for consecutive cases by a blank line.
Sample Input
2   1   100.00    3
100.00    4   210.00

3
1 100.00
2 50.00
5 200.00
7 358.41

  -1

Sample Output
Case 1: 0.01635

Case 2: 0.00520


题意:

jill每隔几个月会在一个固定利率的基金上投资一部分钱。每月会产生一定的利息。现在已知某月底jill账户上的金额,求利率是多少(0~1)。

思路:

一元高次方程的求解。可以用二分法无限逼近正解。有一个坑点,就是输出时需要用%.05f,如果是零的话,小数点后需要输出5个0。

代码:

#include<stdio.h>
#include<string.h>
#include<math.h>
using namespace std;
#define exp 0.000001
double ans,dis[15],val;
int n,power[15],end;
double cal(double p)
{
    double ret=0;
    for(int i=0;i<n;i++)
        ret+=dis[i]*pow(p,end-power[i]+1);
    return ret;
}
double bin(double L,double R)
{

    if(R-L<exp) return L;
    double mid=(L+R)/2;
    double get=cal(mid);
    //printf("->%.5f %.5f %.5f\n",L,R,get);
    if(get>=val) return bin(L,mid);
    else return bin(mid,R);
}
int main()
{
    int cas=1;
    while(scanf("%d",&n) && n!=-1)
    {
        for(int i=0;i<n;i++)
            scanf("%d%lf",&power[i],&dis[i]);
        scanf("%d%lf",&end,&val);
        if(cas>1) printf("\n");
        printf("Case %d: %.05f\n",cas++,bin(1,2)-1);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值