POJ 1860 Currency Exchange [bellman_ford]

传送门:http://poj.org/problem?id=1860


题目:

Time Limit:1000MS Memory Limit:30000KB 64bit IO Format:%I64d & %I64u

Status

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively.
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3.
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2.
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4.

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

思路:若涨钱,则一定存在正环;若存在正环,则钱可以不停的增加,故可以涨钱;所以用bellman_ford判环,但初始化为0,求最长路;


代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<vector>
#include<queue>
#include<stack>
#include<map>
#define INF 0x3f3f3f3f
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;

typedef long long LL;
const int N=100007;

struct Edge{
    int u,v;
    double ra,co;
    Edge(int a=0,int b=0,double c=0,double d=0):u(a),v(b),ra(c),co(d){}
};

vector<Edge> E;
double dis[N];


bool bellman_ford(int s,double v,int n)
{
    for(int i=1;i<=n;i++)
        dis[i]=0;

    dis[s]=v;
    //relax
    for(int i=1;i<=n-1;i++)
    {
        bool flag=false;
        for(int j=0;j<E.size();j++)
        {
            if(dis[E[j].v]<(dis[E[j].u]-E[j].co)*E[j].ra)
            {
                dis[E[j].v]=(dis[E[j].u]-E[j].co)*E[j].ra;
                flag=true;
            }
        }
        if(!flag) return false;
    }

    //Search Positive Circle

    for(int i=0;i<E.size();i++)
    {
        if(dis[E[i].v]<(dis[E[i].u]-E[i].co)*E[i].ra)
            return true;
    }
    return false;
}

int main()
{
    int n,m,s;
    double v;
    while(scanf("%d%d%d%lf",&n,&m,&s,&v)==4)
    {
        E.clear();
        int a,b;
        double ra,ca,rb,cb;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%lf%lf%lf%lf",&a,&b,&ra,&ca,&rb,&cb);
            E.push_back(Edge(a,b,ra,ca));
            E.push_back(Edge(b,a,rb,cb));
        }
        if(bellman_ford(s,v,n))
            printf("YES\n");
        else
            printf("NO\n");

    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值