1002 Grading(2011年浙江大学计算机及软件工程研究生机试真题)

题目描述:

    Grading hundreds of thousands of Graduate Entrance Exams is a hard work. It is even harder to design a process to make the results as fair as possible. One way is to assign each exam problem to 3 independent experts. If they do not agree to each other, a judge is invited to make the final decision. Now you are asked to write a program to help this process.
    For each problem, there is a full-mark P and a tolerance T(<P) given. The grading rules are:
    • A problem will first be assigned to 2 experts, to obtain G1 and G2. If the difference is within the tolerance, that is, if |G1 - G2| ≤ T, this problem's grade will be the average of G1 and G2.
    • If the difference exceeds T, the 3rd expert will give G3.
    • If G3 is within the tolerance with either G1 or G2, but NOT both, then this problem's grade will be the average of G3 and the closest grade.
    • If G3 is within the tolerance with both G1 and G2, then this problem's grade will be the maximum of the three grades.
    • If G3 is within the tolerance with neither G1 nor G2, a judge will give the final grade GJ.

输入:

    Each input file may contain more than one test case.
    Each case occupies a line containing six positive integers: P, T, G1, G2, G3, and GJ, as described in the problem. It is guaranteed that all the grades are valid, that is, in the interval [0, P].

输出:

    For each test case you should output the final grade of the problem in a line. The answer must be accurate to 1 decimal place.

样例输入:
20 2 15 13 10 18
样例输出:
14.0
//Grading
#include<iostream>
#include<cstdlib> 
#include<iomanip>
using namespace std;
int qmax(int x,int y)
{
	return x<y?x:y;
}
int main()
{
	int p,t,g1,g2,g3,g;
	double x;
	while(cin>>p>>t>>g1>>g2>>g3>>g)
	{
		if(abs(g1-g2)<=t)
		{
			x=(g1+g2)/2.0;
			cout<<setprecision(1)<<setiosflags(ios::fixed)<<x<<endl;
			continue;
		}
		else if(abs(g1-g3)>t&&abs(g2-g3)>t)
		{
			x=g;
		  cout<<setprecision(1)<<setiosflags(ios::fixed)<<x<<endl;
		  continue;	
		}
		else if((abs(g1-g3)>t&&abs(g2-g3)<=t)||(abs(g1-g3)<=t&&abs(g2-g3)>t))
		{
		    	if(qmax(abs(g1-g3),abs(g2-g3))==abs(g1-g3))
		    	x=(g1+g3)/2.0;
		    	else 
		        x=(g2+g3)/2.0;
		        cout<<setprecision(1)<<setiosflags(ios::fixed)<<x<<endl;
		        continue;
		}
		else {
			    if(g1>=g2&&g1>=g3)
			    x=g1;
			    else if(g2>=g1&&g2>=g3)
			    x=g2;
			    else 
			    x=g3;
			    cout<<setprecision(1)<<setiosflags(ios::fixed)<<x<<endl;
		        continue;
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Sunshine_gao

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值