POJ 2481——Cows(树状数组)

Cows
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 12694 Accepted: 4222

Description

Farmer John's cows have discovered that the clover growing along the ridge of the hill (which we can think of as a one-dimensional number line) in his field is particularly good. 

Farmer John has N cows (we number the cows from 1 to N). Each of Farmer John's N cows has a range of clover that she particularly likes (these ranges might overlap). The ranges are defined by a closed interval [S,E]. 

But some cows are strong and some are weak. Given two cows: cow i and cow j, their favourite clover range is [Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei - Si > Ej - Sj, we say that cow i is stronger than cow j

For each cow, how many cows are stronger than her? Farmer John needs your help!

Input

The input contains multiple test cases. 
For each test case, the first line is an integer N (1 <= N <= 10 5), which is the number of cows. Then come N lines, the i-th of which contains two integers: S and E(0 <= S < E <= 10 5) specifying the start end location respectively of a range preferred by some cow. Locations are given as distance from the start of the ridge. 

The end of the input contains a single 0.

Output

For each test case, output one line containing n space-separated integers, the i-th of which specifying the number of cows that are stronger than cow i

Sample Input

3
1 2
0 3
3 4
0

Sample Output

1 0 0

————————————————分割线——————————————————

题目大意:

给n个区间,求每个区间被包含的数量


思路:

对于区间[x,y] 对y进行从大到小排序,如果y相等则x从小到大排序。

对于某个区间[x,y],统计前面比x小于等于的点的数量

注意对于区间的判重!还有就是下标要加1,因为起始从0开始

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<map>
#include<utility>
#define M 100000+10
using namespace std;
int c[M],n;
struct node
{
    int x,y,index;
}a[M];
int f[M];
bool cmp(node x,node y)
{
    return (x.y>y.y||(x.y==y.y&&x.x<=y.x));
}
void update(int x,int v)
{
    for(int i=x;i<=M;i+=i&-i){
        c[i]+=v;
    }
}
inline int getsum(int x)
{
    int sum=0;
    for(int i=x;i>0;i-=i&-i){
        sum+=c[i];
    }
    return sum;
}
int main()
{
    while(scanf("%d",&n),n){
        memset(c,0,sizeof(c));
        for(int i=0;i<n;++i){
            scanf("%d %d",&a[i].x,&a[i].y);
            a[i].index=i;
            a[i].x++,a[i].y++;
        }
        sort(a,a+n,cmp);
        for(int i=0;i<n;++i){
            if(i&&a[i].y==a[i-1].y&&a[i].x==a[i-1].x) f[a[i].index]=f[a[i-1].index];
            else f[a[i].index]=getsum(a[i].x);
            update(a[i].x,1);
        }
        for(int i=0;i<n;++i){
            printf("%d",f[i]);
            if(i!=n-1) printf(" ");
        }
        printf("\n");

    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值