POJ 2828——Buy Tickets(树状数组,线段树——逆序遍历)

Buy Tickets
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 13496 Accepted: 6726

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i(1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243


————————————————————分割线————————————————————


题目大意:

排队买票,有n个人,每个人有两个信息pos[i],val[i],   其中pos[i]表示第i个人站在第pos[i]个人的右边,求最后的序列val[i]


思路:

逆序遍历,则pos[i]转变为第i个人前面有多少个空位

1:树状数组BIT

                    假设第i个人的位置为P,则要满足p-sum[p]=pos[i],二分查找即可

2:线段树ST

                   每个节点记录当前区间的剩余长度,当有人插队的时候,优先考虑左边,再右边,当某个人插到指定位置后,向上更新到父亲节点,包含的剩余长度-1



1.树状数组code

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
const int maxn=200001;
using namespace std;
int n,f[maxn];
int c[maxn+1];
struct node
{
    int x,y;
}a[maxn+1];
void update(int x,int v)
{
    for(int i=x;i<=maxn;i+=i&-i){
        c[i]+=v;
    }
}
int getsum(int x)
{
    int sum=0;
    for(int i=x;i>0;i-=i&-i){
        sum+=c[i];
    }
    return sum;
}
int Binary_search(int x,int y)
{
    int l=2,r=n+1;
    while(l<r){
        int m=(l+r)>>1;
        int tmp=m-getsum(m)-1;
        if(tmp>=x) r=m;
        else l=m+1;
    }
    f[l]=y;
    return l;
}
int main()
{
    while(scanf("%d",&n)!=EOF){
        memset(c,0,sizeof(c));
        for(int i=0;i<n;++i){
            scanf("%d %d",&a[i].x,&a[i].y);
            a[i].x++;
        }
        for(int i=n-1;i>=0;--i){
            update(Binary_search(a[i].x,a[i].y),1);
        }
        for(int i=2;i<=n+1;++i){
            printf("%d",f[i]);
            if(i!=n+1) printf(" ");
        }
        puts(" ");
    }
    return 0;
}



2:线段树

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define local
const int maxn=200001;
using namespace std;
int n,f[maxn+1];
struct node
{
    int x,y;
}a[maxn+1];
int len[maxn<<2];
void push_up(int rt)
{
    len[rt]=len[rt<<1]+len[rt<<1|1];
}
void build(int l,int r,int rt)
{
    if(l==r){
        len[rt]=1;
        return ;
    }
    int m=(l+r)>>1;
    build(lson);
    build(rson);
    push_up(rt);
}
void query(int x,int y,int l,int r,int rt)
{
    if(l==r){
        len[rt]--;
        f[l]=y;
        return ;
    }
    int m=(l+r)>>1;
    if(len[rt<<1] >=x){
        query(x,y,lson);
    }
    else query(x-len[rt<<1],y,rson);
    push_up(rt);
}
int main()
{
    while(scanf("%d",&n)!=EOF){

        for(int i=0;i<n;++i){
            scanf("%d %d",&a[i].x,&a[i].y);
            a[i].x++;
        }
        build(1,n,1);
        for(int i=n-1;i>=0;--i){
            query(a[i].x,a[i].y,1,n,1);
        }
        for(int i=1;i<=n;++i){
            printf("%d",f[i]);
            if(i!=n) printf(" ");
        }
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值