POJ-2002 Squares

Time Limit: 3500MS Memory Limit: 65536K
Total Submissions: 18416 Accepted: 7081

Description

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property.

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates.

Input

The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.

Output

For each test case, print on a line the number of squares one can form from the given stars.

Sample Input

4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0

Sample Output

1
6
1

Source

Rocky Mountain 2004

分析: 暴力枚举两点(对角线或一边),然后用hash判断另外两点是否存在, 向量旋转公式为:[x*cosA-y*sinA  x*sinA+y*cosA] 。
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
struct POINT
{
	int x,y; 
} point[1001],f[117007];
bool jud[117007];
int n,ans;
void insert(int x,int y)
{
	int k=(abs(x)*10+abs(y))%107007;
	while(jud[k] && (f[k].x != x || f[k].y != y)) k++;
	if(!jud[k])
	{
		jud[k]=true;
		f[k].x=x;
		f[k].y=y;
	}
}
bool Find(int x,int y)
{
	int k=(abs(x)*10+abs(y))%107007;
	while(jud[k] && (f[k].x != x || f[k].y != y)) k++;
	if(!jud[k]) return false;
	return true;
}
int main()
{
	cin.sync_with_stdio(false);
	while(cin >> n && n)
	{
		ans=0;
		memset(jud,0,sizeof(jud));
		for(int i=1;i <= n;i++)
		{
			cin>>point[i].x>>point[i].y;
			insert(point[i].x,point[i].y);
		} 
		for(int i=1;i <= n;i++)
		 for(int j=1;j <= n;j++)
		  if(point[j].x > point[i].x && point[j].y > point[i].y)
		  {
		  	int a=point[i].x,b=point[i].y,x=point[j].x,y=point[j].y;
		  	if((x-a == y-b) && Find(a,y) && Find(x,b)) ans++;
		  	int dx=b-y,dy=x-a;
		  	if(Find(x+dx,y+dy) && Find(a+dx,b+dy)) ans++;
		  }
		cout<<ans<<endl;
	}
 } 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值