LA 4725 Airport

50 篇文章 0 订阅

Airport

A big city has an international airport handling 40 million passengers a year. But this is notorious as one of the most congested airports in the world. In this airport, there is only one landing strip as in the above figure. Therefore the landing strip is always crowded with a lot of aircrafts waiting for a takeoff. There are two ways, say west-roadW and east-roadE, to approach the landing strip. The aircrafts are waiting for a takeoff on the two roads as in the above figure.

\epsfbox{p4725.eps}

At each time t, an arbitrary number of aircrafts arrive on the roadsW andE. Each aircraft arriving onW orE at time t receives a rank, which is equal to the number of the waiting aircrafts on the same road to precede it. Then the one ofW andE is chosen by a control tower, and the most front aircraft on the road leaves the ground. Given an information of the arriving aircrafts at times, we are concerned in the takeoff schedule of the control tower to minimize the maximum rank of the aircrafts.

  roads  
   WE
times    
 1 A1,A2,A3B1,B2
 2  B3,B4,B5
 3 A4,A5 

For example, the above table represents the aircrafts arriving on the roads W and E at each time. At time 1, the aircraftsA1,A2 andA3 receive the ranks 0, 1 and 2, respectively, and the aircraftsB1 andB2 receive the ranks 0 and 1, respectively. Then the control tower allows the aircraftB1 on the roadE to take off, and B1 leaves the ground. At time 2, the aircraftsB3,B4, andB5 receive the ranks 1, 2 and 3, respectively. ThenA1 on the roadW is allowed to take off, and it leaves the ground. At time 3, the aircraftsA4 andA5 receive the ranks 2 and 3, respectively. So the maximum rank of the aircrafts is 3, and this is the minimum of the maximum rank over all the possible takeoff schedules.

Input 

Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given on the first line of the input. The first line of each test case contains an integern(1$ \le$n$ \le$5000) , the number of times. In the next n lines of each test case, thei-th line contains two integer numbersai and bi, representing the number of arriving aircrafts on the roadW andE, respectively, at timei, where0$ \le$ai,bi$ \le$20.

Output 

Your program is to write to standard output. Print exactly one line for each test case. The line contains the minimum of the maximum rank over all the possible takeoff schedules.

The following shows sample input and ouput for three test cases.

Sample Input 

3 
1 
1 1
3 
3 2
0 3
2 0
6 
0 1
1 1
1 2
1 1
1 1
6 0

Sample Output 

0 
3 
5


题目大意:W E 两条跑道,两个跑道里面的飞机编号为0,1,2。。每个时刻只能起飞任一跑道里面的一架飞机,然后重新编号,每个时刻会有ai bi架飞机到达跑到后面,给你时间表,每个时刻到达的飞机数,求最大编号的最小值


分析:二分+判断,另外自己的代码一直WA,交了网上的所有标程都是WA,什么情况。


#include <iostream>
#include <cstdio>
#define MAXN 5001
using namespace std;
int T,n,a[MAXN],b[MAXN];
bool check(int MAX)
{
	int asum = 0,bsum = 0,time = 0;
	for(int i = 1;i <= n;i++)
	{
		asum += a[i];
		bsum += b[i];
		if(asum > MAX) 
		{
			time -= (asum - MAX);
			asum = MAX;
		}
		if(bsum > MAX) 
		{
			time -= (bsum - MAX);
			bsum = MAX;
		}
		if(time < 0) return false;
		if(asum + bsum > time)
		 if(asum && bsum == 0) asum--;
		  else 
		   if(bsum && asum == 0) bsum--;
		    else time++;	
	}
	return true;
} 
int main()
{
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&n);
		int tota = 0,totb = 0;
		for(int i = 1;i <= n;i++)
		{
			scanf("%d %d",&a[i],&b[i]);
			tota += a[i];
			totb += b[i];
		}
		int s = 1,t = max(tota,totb);
		while(s < t)
		{
			int mid = (s + t)/2;
			if(check(mid)) t = mid;
			else s = mid+1; 
		}
		printf("%d\n",s-1);
	} 
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值