阶乘的精确值

描述:输入不超过1000的正整数n,输出 n! = 1*2*3*4*5* ……*n的精确值。

样例输入:30

样例输出:265252859812191058636308480000000


#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;

#define Max 3000

int main()
{
	int f[Max] = {0} ;
//	memset(f,0);
	f[0] = 1;
	
	int n;
	int s=0,c=0;
	cout<<"请输入想要求的阶乘的值n:";
	cin>>n;
	for(int i=2;i<=n;i++)
	{
		for(int j=0;j<Max; j++)
		{
			s= f[j] * i + c;
			f[j] = s % 10;
			c = s / 10;
		}
	} 
	int k = 0;
	for( k=Max-1;k>=0;--k)
	{
		if( f[k])
		break;
	}
	for(int j=k;j>=0;--j)
		cout<<f[j];
	cout<<endl;
	return 0;
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值