字符串 模拟 Spell checker (poj 1035)

Language:
Spell checker
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 19252 Accepted: 7040

Description

You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms. 
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations: 
?deleting of one letter from the word; 
?replacing of one letter in the word with an arbitrary letter; 
?inserting of one arbitrary letter into the word. 
Your task is to write the program that will find all possible replacements from the dictionary for every given word. 

Input

The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary. 
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked. 
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most. 

Output

Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.

Sample Input

i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#

Sample Output

me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me

Source

题意:给出一个字典,再给出若干单词,根据字典判断单词的正确性,若正确输出correct,若错误且它能够通过插入一个字母,删除一个字母,替换一个字母使它正确,输出更改后的单词,并按照给出字典的字典序输出。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 1005
#define MAXN 2005
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
typedef long long ll;
using namespace std;

char word[10010][18];
int len[10010];
char str[18];
int l;

bool OK(int pos)
{
//    printf("%s\n",str);
    int a=abs(l-len[pos]);
    if (a>1)  //长度相差大于一直接退出
        return false;
    if (l==len[pos])
    {
        int s=0;
        for (int i=0;i<l;i++)
        {
            if (str[i]!=word[pos][i])
                s++;
        }
        if (s==1)
            return true;
        else
            return false;
    }
    else if (l<len[pos])
    {
        int s=0,ls=0,lw=0;
        while (lw<len[pos])
        {
            if (str[ls]==word[pos][lw])
            {
                ls++;
                lw++;
            }
            else
            {
                s++;
                lw++;
            }
        }
        if (s==1)
            return true;
        else
            return false;
    }
    else
    {
        int s=0,ls=0,lw=0;
        while (ls<l)
        {
            if (str[ls]==word[pos][lw])
            {
                ls++;
                lw++;
            }
            else
            {
                s++;
                ls++;
            }
        }
        if (s==1)
            return true;
        else
            return false;
    }
}

int main()
{
    int i,j,num;
    num=0;
    while (scanf("%s",word[num]))
    {
        if (word[num][0]=='#')
            break;
        len[num]=strlen(word[num]);
        num++;
    }
    while (scanf("%s",str))
    {
        if (str[0]=='#')
            break;
        for (i=0;i<num;i++)
        {
            if (strcmp(str,word[i])==0)
            {
                printf("%s is correct\n",str);
                break;
            }
        }
        if (i<num)
            continue;
        l=strlen(str);
        printf("%s:",str);
        for (i=0;i<num;i++)
        {
            if (OK(i))
            {
                printf(" %s",word[i]);
            }
        }
        printf("\n");
    }
    return 0;
}




  • 4
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值