Network Saboteur (poj 2531 dfs)

46 篇文章 0 订阅
Language:
Network Saboteur
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9379 Accepted: 4430

Description

A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts. 
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks. 
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him. 
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).

Input

The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000). 
Output file must contain a single integer -- the maximum traffic between the subnetworks. 

Output

Output must contain a single integer -- the maximum traffic between the subnetworks.

Sample Input

3
0 50 30
50 0 40
30 40 0

Sample Output

90

Source

Northeastern Europe 2002, Far-Eastern Subregion

题意:给一个无向图,把它分成两部分,使得连接这两部分边的权和最大

思路:定义一个group数组标记每个点的分组,从0号点dfs直到N,暴搜所有情况求最大值。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 1005
#define MAXN 2005
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
typedef long long ll;
using namespace std;

int mp[25][25];
int group[25];//标记分组
int N,ans;

void dfs(int d,int sum)
{
    if (d==N)
    {
        if (sum>ans)
            ans=sum;
        return ;
    }
    int all=0;
    for (int i=0;i!=d;i++)
        if (group[i]==1)
            all+=mp[d][i];
    group[d]=2;
    dfs(d+1,sum+all);
    all=0;
    for (int i=0;i!=d;i++)
        if (group[i]==2)
            all+=mp[d][i];
    group[d]=1;
    dfs(d+1,sum+all);
}

int main()
{
    scanf("%d",&N);
    for (int i=0;i<N;i++)
        for (int j=0;j<N;j++)
            scanf ("%d",&mp[i][j]);
    ans=-1;
    dfs(0,0);
    printf("%d\n",ans);
    return 0;
}
/*
3
0 50 30
50 0 40
30 40 0
*/


  • 4
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值