Channel Allocation (poj 1129 dfs)

46 篇文章 0 订阅

Language:
Channel Allocation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 12367 Accepted: 6325

Description

When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere with one another. This condition is satisfied if adjacent repeaters use different channels. 

Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of channels required.

Input

The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For example, ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters indicates the end of input. 

Following the number of repeaters is a list of adjacency relationships. Each line has the form: 

A:BCDH 

which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line has the form 

A: 

The repeaters are listed in alphabetical order. 

Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross. 

Output

For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form when only one channel is required.

Sample Input

2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0

Sample Output

1 channel needed.
3 channels needed.
4 channels needed. 

Source

题意:给你一个n,代表电台的数量。电台的编号是从A到Z。然后给你他们之间的邻接关系,让你求出最小需要的频率数。要求任意两个相邻的电台之间不允许用同一频率。

思路:数据不大,最多26,dfs暴力,用邻接表存图,color[x]=i表示x号电台使用i频率。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 30
#define MAXN 2005
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
typedef long long ll;
using namespace std;

struct Edge
{
    int u,v;
    int next;
}edge[maxn*maxn];

int N,edgenum;
int head[maxn];
int color[maxn];

void addedge(int u,int v)
{
    edge[edgenum].v=v;
    edge[edgenum].next=head[u];
    head[u]=edgenum++;
}

bool ISok(int x)
{
    for (int i=head[x];i!=-1;i=edge[i].next)
    {
        if (color[x]==color[edge[i].v])
            return false;
    }
    return true;
}

bool dfs(int point_num,int color_num)
{
    if (point_num>N)
        return true;
    for (int i=1;i<=color_num;i++)
    {
        color[point_num]=i;
        if (ISok(point_num))
        {
            if (dfs(point_num+1,color_num))
                return true;
        }
        color[point_num]=0;
    }
    return false;
}

int main()
{
    while (scanf("%d",&N)&&N)
    {
        getchar();
        memset(head,-1,sizeof(head));
        memset(color,0,sizeof(color));
        edgenum=0;
        for (int i=1;i<=N;i++)
        {
            getchar();
            getchar();
            char ch;
            while (ch=getchar())
            {
                if (ch=='\n')
                    break;
                addedge(i,ch-'A'+1);
            }
        }
        for (int i=1;i<=N;i++)//从1~N枚举颜色种类数
        {
            if (dfs(1,i))
            {
                if (i==1)//注意一个频率是用channel,多个时用channels
                    printf("1 channel needed.\n");
                else
                    printf("%d channels needed.\n",i);
                break;
            }
        }
    }
    return 0;
}
/*
2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0
*/


  • 4
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值