Cake (hdu 5355 构造+dfs)

46 篇文章 0 订阅
7 篇文章 0 订阅

Cake

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1867    Accepted Submission(s): 350
Special Judge


Problem Description
There are  m  soda and today is their birthday. The  1 -st soda has prepared  n  cakes with size  1,2,,n . Now  1 -st soda wants to divide the cakes into  m  parts so that the total size of each part is equal. 

Note that you cannot divide a whole cake into small pieces that is each cake must be complete in the  m  parts. Each cake must belong to exact one of  m  parts.
 

Input
There are multiple test cases. The first line of input contains an integer  T , indicating the number of test cases. For each test case:

The first contains two integers  n  and  m   (1n105,2m10) , the number of cakes and the number of soda.
It is guaranteed that the total number of soda in the input doesn’t exceed 1000000. The number of test cases in the input doesn’t exceed 1000.
 

Output
For each test case, output "YES" (without the quotes) if it is possible, otherwise output "NO" in the first line.

If it is possible, then output  m  lines denoting the  m  parts. The first number  si  of  i -th line is the number of cakes in  i -th part. Then  si  numbers follow denoting the size of cakes in  i -th part. If there are multiple solutions, print any of them.
 

Sample Input
  
  
4 1 2 5 3 5 2 9 3
 

Sample Output
  
  
NO YES 1 5 2 1 4 2 2 3 NO YES 3 1 5 9 3 2 6 7 3 3 4 8
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5368  5367  5366  5365  5364 


题意:有n个蛋糕,大小分别为1~n,问是否可以将它们平分为m份,输出方案。

思路:不能直接从后往前贪心,具体看这位大神博客,很详细点击打开链接 另外不知道4*m是怎么得到的不清楚,望知道的可以解答一下~

代码:

#include <iostream>
#include <functional>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define pi acos(-1.0)
#define eps 1e-6
#define lson rt<<1,l,mid
#define rson rt<<1|1,mid+1,r
#define FRE(i,a,b)  for(i = a; i <= b; i++)
#define FREE(i,a,b) for(i = a; i >= b; i--)
#define FRL(i,a,b)  for(i = a; i < b; i++)
#define FRLL(i,a,b) for(i = a; i > b; i--)
#define mem(t, v)   memset ((t) , v, sizeof(t))
#define sf(n)       scanf("%d", &n)
#define sff(a,b)    scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define pf          printf
#define DBG         pf("Hi\n")
typedef long long ll;
using namespace std;

#define INF 0x3f3f3f3f
#define mod 1000000009
const int maxn = 200100;
const int MAXN = 2005;
const int MAXM = 200010;
const int N = 1005;

int n,m;
int ans[12][maxn];
ll sum,ave;
bool vis[50];

void init()
{
    while (n>4*m)
    {
        for (int i=1;i<=m;i++)
        {
            ans[i][++ans[i][0]]=n-2*m+i;
            ans[i][++ans[i][0]]=n-i+1;
        }
        ave-=(ll)(2*n+1-2*m);
        n-=2*m;
    }
    memset(vis,false,sizeof(vis));
}

bool dfs(int left,int len,int pos,int num)
{
    if (num==m+1) return true;
    if (left==0) return dfs(len,len,n,num+1);
    for (int i=pos;i>=1;i--)
    {
        if (vis[i]||i>left) continue;
        vis[i]=true;
        ans[num][++ans[num][0]]=i;
        if (dfs(left-i,len,i-1,num)) return true;
        vis[i]=false;
        --ans[num][0];
    }
    return false;
}

int main()
{
#ifndef ONLINE_JUDGE
    freopen("C:/Users/lyf/Desktop/IN.txt","r",stdin);
#endif
    int i,j,t;
    scanf("%d",&t);
    while (t--)
    {
        scanf("%d%d",&n,&m);
        for (i=1;i<=10;i++) ans[i][0]=0;
        sum=(ll)n*(n+1)/2;
        if (sum%m||sum/m<n)
        {
            printf("NO\n");
            continue;
        }
        ave=sum/(ll)m;

        init();

        printf("YES\n");
        dfs((int)ave,(int)ave,n,1);
        for (i=1;i<=m;i++)
        {
            printf("%d",ans[i][0]);
            for (j=1;j<=ans[i][0];j++)
                printf(" %d",ans[i][j]);
            printf("\n");
        }
    }
    return 0;
}



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值