UVa 575 Skew Binary 歪斜二进制

呵呵,这个翻译还是很直白的嘛,大家意会就好。

第一次看到这个高大上题目还是有点小害怕的,还好题没有做过深的文章。

只要按照规则转化成十进制就好了,而且题目本身也说了最大不超过一个int的范围(2^31-1 == 2147483647)。

直接位运算就好了。



  Skew Binary 

When a number is expressed in decimal, the k-th digit represents a multiple of 10k. (Digits are numbered from right to left, where the least significant digit is number 0.) For example, 

\begin{displaymath}81307_{10} = 8 \times 10^4 + 1 \times 10^3 + 3 \times 10^2 + ......mes 10^1 +7 \times 10 0 = 80000 + 1000 + 300 + 0 + 7= 81307.\end{displaymath}

When a number is expressed in binary, the k-th digit represents a multiple of 2k. For example, 

\begin{displaymath}10011_2 = 1 \times 2^4 + 0 \times 2^3 + 0 \times 2^2 + 1 \times 2^1 +1 \times 2^0 = 16 + 0 + 0 + 2 + 1 = 19.\end{displaymath}

In skew binary, the k-th digit represents a multiple of 2k+1 - 1. The only possible digits are 0 and 1, except that the least-significant nonzero digit can be a 2. For example, 

\begin{displaymath}10120_{skew} = 1 \times (2^5 - 1) + 0 \times (2^4-1) + 1 \tim......2 \times (2^2-1) + 0 \times (2^1-1)= 31 + 0 + 7 + 6 + 0 = 44.\end{displaymath}

The first 10 numbers in skew binary are 0, 1, 2, 10, 11, 12, 20, 100, 101, and 102. (Skew binary is useful in some applications because it is possible to add 1 with at most one carry. However, this has nothing to do with the current problem.)

Input 

The input file contains one or more lines, each of which contains an integer  n . If  n  = 0 it signals the end of the input, and otherwise  n  is a nonnegative integer in skew binary.

Output 

For each number, output the decimal equivalent. The decimal value of  n  will be at most  2 31  - 1 = 2147483647.

Sample Input 

10120
200000000000000000000000000000
10
1000000000000000000000000000000
11
100
11111000001110000101101102000
0

Sample Output 

44
2147483646
3
2147483647
4
7
1041110737



Miguel A. Revilla 
1998-03-10
AC代码:

//#define LOCAL
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

char SkBinary[35];

void Reverse(char s[], int l);

int main(void)
{
	#ifdef LOCAL
		freopen("575in.txt", "r", stdin);
	#endif

	while(gets(SkBinary) && SkBinary[0] != '0')
	{
		int l = strlen(SkBinary);
		Reverse(SkBinary, l);
		int i, n = 0;
		for(i = 0; i < l; ++i)
		{
			if(SkBinary[i] == '0')
				continue;
			if(SkBinary[i] == '1')
				n += (1 << (i + 1)) - 1;
			if(SkBinary[i] == '2')
				n += (1 << (i + 2)) - 2;
		}
		cout << n << endl;
	}
	return 0;
}
//用来反转数组
void Reverse(char s[], int l)
{
	int i;
	char t;
	for(i = 0; i < l / 2; ++i)
	{
		t = s[i];
		s[i] = s[l - i -1];
		s[l - i -1] = t;
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值