zoj 1406 Jungle Roads(最小生成树))

Jungle Roads

Time Limit: 2 Seconds       Memory Limit: 65536 KB

The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.


Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0


Sample Output

216
30

有n个村子,n个村子用大写字母标明,每个测试数据有n-1行数据,每行的第一个数据都是表示村子的大写字母,每行数据代表一个村子,首先是这个村子的字母,然后是整数k,表示与该村子相连的道路有k条,接下来是k条道路信息,首先是村子字母,然后是维护费用。

求道路网络的最小维护费用。

最小生成树问题

#include <iostream>
#include <algorithm>
using namespace std;
int Father[40];
struct node
{
    char a;
    char b;
    int w;
};
int cmp(node a,node b)
{
    return a.w<b.w;
}
int Find(int x)
{
    while (x!=Father[x])
    {
        x=Father[x];
    }
    return x;
}
void Union(int x,int y)
{
    x=Find(x);
    y=Find(y);
    if(x!=y)
    {
        Father[x]=y;
    }
}
int main()
{
    int n;
    node num[10000];
    int ans,sum;
    char ch;
    while (cin>>n && n)
    {
        ans=0;
        sum=0;
        int m;
        char ch2;
        for (int i=0; i<=n; i++)
        {
            Father[i]=i;
        }
        for (int i=0; i<n-1; i++)
        {
            cin>>ch;
            cin>>m;
            if(m>0)
            {
                for (int j=0; j<m; j++)
                {
                    cin>>ch2;
                    num[ans].a=ch;
                    num[ans].b=ch2;
                    cin>>num[ans].w;
                    ans++;
                }
            }
        }
        sort(num, num+ans, cmp);
        int k=0;
        for (int i=0; i<ans; i++)
        {
            int x=Find(num[i].a-'A');  //将字符转换成数字计算
            int y=Find(num[i].b-'A');
            if(x!=y)
            {
                Union(x, y);
                sum+=num[i].w;
                k++;
            }
            if(k>=n-1)
            {
                break;
            }
        }
        cout<<sum<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值