hdu 1671 Phone List(Trie树)

Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input
  
  
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 

Sample Output
  
  
NO YES

学习Trie树的题

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
typedef struct trie
{
    int cnt;
    bool end;
    struct trie *next[26];
    trie()
    {
        
        this->cnt=1;
        this->end=false;
        memset(next, 0, sizeof(next));
    }

    
}Trie;
bool flag;
void BuildTrie(char *s,Trie *&root) //建树
{
    Trie *p=root;
    Trie *q;
    int len=strlen(s);
    int j;
    int count=0;
    for (int i=0; i<len; i++)
    {
        j=s[i]-'0';
        if(p->end)
        {
            flag=true;
            return;
        }
        if(!p->next[j])
        {
            q=new Trie();
            p->next[j]=q;
        }
        else
        {
           // p->next[j]->cnt++;
            count++;
        }
        p=p->next[j];
    }
    p->end=true;          //单词结束加标记
    if(count==strlen(s))  //存在前缀
    {
        flag=true;
    }
}
void DeleteTrie(Trie *&root) //释放空间
{
    for (int i=0; i<=9; i++)
    {
        if(root->next[i])
        {
            DeleteTrie(root->next[i]);
        }
    }
    delete root;
}
int main()
{
    int n,t;
    char s[20];
    Trie *root;
    scanf("%d",&t);
    while (t--)
    {
        root=new Trie();
        scanf("%d",&n);
        flag=false;
        while (n--)
        {
            scanf("%s",s);
            if(!flag)
                BuildTrie(s, root);
        }
        if(!flag)
            printf("YES\n");
        else
            printf("NO\n");
        DeleteTrie(root);
    }
    
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值